1 Reply Latest reply on Feb 4, 2017 9:11 AM by ldstang

    Can NOT open an epub book on Mac

    ldstang

      Yes, there are already several others who have raised this question. I, too, had v1.7 which had been working up until I tried to download a short book. So, I installed the latest version of ADE, but it still won't let me open this book (failed to get license) in either version. Then, since the library had updated their Overdrive, I installed that as well, but it doesn't address the real issue here of using ADE to get the book itself! Then I tried to de-authorize ADE, but that didn't go anywhere either (it says to try again later.... how many times and how much later can that be!!). So, I've complained to my library about the problem, but really feel it's in ADE trying to use that .acsm token to access/download the book and failing. I've had this Mac for 5 years and always used it to download eBooks from libraries via Overdrive. My last successful download was Oct 31, 2016 and I think I used v1.7 on Mac OS 10.11 (El Capitan).

       

      This is so frustrating... things were working for quite awhile with v1.7 and v4.5 is not helping at all.

       

      --lydia stang