3 Replies Latest reply on Feb 5, 2017 1:00 PM by kerrishotts

    App fail to build

    slimkyd70099163

      Getting error for crosswork, but it was build 2weeks ago with crosswalk and now try to update app, it gives crosswalk error.

       

      When i remove crosswalk from config.xml, it builds successfully. I an seems to find the problem. Please help

       

      Below is the error:

       

      /project/src/org/crosswalk/engine/XWalkWebViewEngine.java:47: error: XWalkWebViewEngine is not abstract and does not override abstract method evaluateJavascript(String,ValueCallback<String>) in CordovaWebViewEngine

      public class XWalkWebViewEngine implements CordovaWebViewEngine {

        ^

      Note: /project/src/org/crosswalk/engine/XWalkCordovaResourceClient.java uses or overrides a deprecated API.

      Note: Recompile with -Xlint:deprecation for details.

      1 error

       

      FAILURE: Build failed with an exception.