9 Replies Latest reply on Mar 30, 2018 2:35 PM by ChrisCrystalize

    Animation Codec no longer exports alpha channel

    Felix29 Level 1

      With the latest upgrade of After Effects I can no longer export an alpha channel using the animation codec. I am working with a Grass Valley K2 Summit server.

      When clip is rendered RGB+Alpha is on. Premult is on. When imported to K2 both tracks appear in the properties box but fill and alpha track are black on clip load.

      With an older version of AE we were able to get the import to work using the aforementioned settings. Any updated computer with AE CC 2017 will not import! Have tried other codecs (DNxHD & opa1) but  still no alpha! Since Apple is no longer supporting Quicktime is this causing an issue? Anyone else experiencing this problem?

      I've made inquires at GVG as well. Hoping to solve this before baseball season starts!

        • 1. Re: Animation Codec no longer exports alpha channel
          Rick Gerard Adobe Community Professional & MVP

          Just tested with no problems. BTW, Straight Alpha is almost always preferred over Pre-multiplied. You get better edges in the composite but it looks worse in a media player.

           

          What happens if you just use the default Lossless with Alpha preset that comes with AE in the Render Cue's output module? What happens if you import the render back into AE and check for an alpha channel.

          • 2. Re: Animation Codec no longer exports alpha channel
            jeffreyp9120215

            Think it must be a GVG issue. I've exported/with alpha several projects both straight and pre-multiplied.. no problem. I just delivered several files to a client who is working with avid on a mac. I'm using AE on a PC. No issues!

            • 3. Re: Animation Codec no longer exports alpha channel
              Felix29 Level 1

              Thanks to both of you. I have narrowed the problem down to After Effects. Out of 5 computers we are running 3 are able to make the export with alpha no issues. The other two however, will not. One of these is running win7 the other win10. Have double checked all render setting between working and nonworking machines. I've found that the K2 is not at fault. If I render a project with alpha and export it as a quicktime(millions of colors+) to one of the machines that has an issue and then export it to the server all is well! So that only leaves an After Effects problem. Could it be a codec issue? Is there a way to update or upgrade the codecs in theses two machines? If it was just the win10 computer I could blame windows 10 but the other is running seven! Can seem to crack this nut!

              • 4. Re: Animation Codec no longer exports alpha channel
                Felix29 Level 1

                This problem has been solved! Apparently any version of After Effects higher than 13.8 will not properly encode a clip for export to a GVG K2 Summit. I've made Adobe aware of the issue. I don't know if the bug affects other servers. If your having a problem getting clips to your server I suggest rolling back to AE 13.5.

                • 5. Re: Animation Codec no longer exports alpha channel
                  geninfogr05g4375690 Level 1

                  I have the same problem. Since After-Effects cc2017 (maybe the problem was there with cc2015, I didn't use it) I can't use a .mov file with an alpha channel. The only way I've found to work around that is, after my render in After-Effect cc2017, I render the .mov file with After-Effects cc2014. Same settings (file format, codec and everything) and it works. Don't know why. So I must keep that old version of After-Effects...

                   

                  Oh by the way, I accidentally removed cc2014 when I upgrade to cc2018. I re-installed it and it still works with cc2014. That gives me the impression that this issue comes from newer versions of After-Effects instead of a codec version.

                  • 6. Re: Animation Codec no longer exports alpha channel
                    MidcoMarketing

                    I have been experiencing these same issues with the Grass Valley Solo, and newer versions of After Effects and Media Encoder.

                    Not sure which company is to blame here?

                    Is it Adobe for changing the way the file gets exported? Or Grass Valley for not updating their products to allow the files to import? At some point, soon I'm afraid, there will be no way to use these older versions of AE (I use AE 2015 release 13.5.0.347 on Win10) to render the proper files. The rest of the creative world is moving on to the new releases of AE and Premiere Pro and not looking back.

                    • 7. Re: Animation Codec no longer exports alpha channel
                      ChrisCrystalize Level 1

                      I have made absolutely no changed to my Adobe CC AE 2017 and less than a month ago I was able to save a file in Quicktime format with RGB+Alpha as I always did with files I've keyed out the background color in AE. Now when I do that the RGB+Alpha option is grayed out and I had to use AVI format which results in a huge file. I would really like to unravel the mystery here if anybody can offer up a few suggestions. Thank you,

                       

                      Chris

                      • 8. Re: Animation Codec no longer exports alpha channel
                        ChrisCrystalize Level 1

                        IMG_20180330_161935.jpg

                        I had to take a picture with my cell phone because this menu droop down would disappear when using the snipping tool. I no longer have the option to save as a RGB+Alpha in Quicktime anymore so this means I can no longer employ keying transparency anymore with AE 2017. I can no longer save videos with transparency to use with my projects (RGB + Alpha is now grayed out). I changed nothing here over the last month with my Adobe suite and have been able to successfully do this in the past; save a file in quicktime with an alpha channel so the background is keyed out (after using keylight 1.2 on an MP$ file with a green background so only the object will be seen). Now that ability is no longer available to me. I'll gladly provide someone with a screen capture of my steps if they would provide me an email address to send a video file to. I absolutely need to be able to use this technology. Please, somebody shed some light on why I can no longer save a keyed out file as RGB+ Alpha in QuickTime format. I was successfully able to do this less than month ago on the same computer and the same installation of After Effects. Meanwhile looks like I'm back to using Power Point for some of my work here, a very archaic program as compared to After Effects.

                         

                        Please somebody in the know send me an email address so I can show you my steps in a screen capture video. I have to figure this out even if it costs money.

                        • 9. Re: Animation Codec no longer exports alpha channel
                          ChrisCrystalize Level 1

                          When I save as an AVI format with RGB+Alpha the background color is not keyed out. I took a file capture of my steps but the video file is too large to post here. The entire color keying technology is now no longer available to me.