2 Replies Latest reply on Feb 12, 2017 7:56 AM by BludgerFilms

    Lightroom Mac won't Import, Gets Stuck.

    BludgerFilms Level 1

      So only today has this started happening, latest version of Lightroom, latest PC updates all done, not sure what is going on. Importing straight from Canon 7D via usb, always done it this way, no card reader. I click import, select the photos and press to import, then stuck on import screen with progress bar not changing.

      Couldn't find any answers anywhere so not sure what else to do after basic troubleshooting.

      Thanks.

        • 1. Re: Lightroom Mac won't Import, Gets Stuck.
          dj_paige Level 9

          Make sure the cable is properly connected at both ends. Try a different cable. Try a card reader (borrow one if necessary). Try a different camera if you have one. Try a different camera card. Try a different computer if possible.

           

          By the way, in the future it would help if you state the version NUMBER of your LR and operating system, and not that you have the latest version because many times people say this and they are mistaken.

          • 2. Re: Lightroom Mac won't Import, Gets Stuck.
            BludgerFilms Level 1

            Thank you for your reply,

            So I have tried all the above I could, different cable, different PC, different card, unable to get a different camera or a card reader for this computer. But the issue seems to be specifically this Mac and Lightroom. Tried using an older version of Lightroom, a new catalogue but nothing worked.

            Super strange though, it was working fine just the day before.