1 Reply Latest reply on Feb 12, 2017 1:58 PM by Just Shoot Me

    OS 10.12 compatibility with elements

    honeybgirl

      I bought a copy of the bundled Photoshop Elements & Premiere Elements 15 at Staples and the package says it's compatible with versions OS10.10 or 10.11.

      I have OS 10.12, specifically 10.12.3.    Will it work?

      I see adobe.com website says the bundle will work with 10.12, but is the copy I have an earlier version (I don't know if Adobe releases updated versions in boxes)?

      Just concerned because the package doesn't say it's compatible with OS 10.12.

      I am hoping to get an answer before I open the package and risk wasting money.

      Thanks