3 Replies Latest reply on Feb 14, 2017 7:39 AM by resdesign

    Video sound

    Spout Level 1

      Hello, I use this code to load a video, but i can not turn the sound On/Off with a simple button

       

      var myImagetag = '<video src="Myvideo.mp4" width="100%" height="100%" autoplay="true" loop="true" muted="true" controls="false" frameborder="0" />';

      sym.getSymbol("Clip").$("ClipVideo").html(myImagetag);

       

      Button code i use :

       

      var video = sym.getSymbol("Clip").$("ClipVideo")[0];

      video.muted = !video.muted;

       

      is anybody has any idea to resolve that ?

      thank you

        • 1. Re: Video sound
          resdesign Adobe Community Professional & MVP

          What version of EA do you have. In the last 2 versions you should be able to load the video with the controls and the user can use these controls to mute the video.

          Otherwise on older version you could use EdgeHero library and use these controls.

          • 2. Re: Video sound
            Spout Level 1

            Hello, I needed this specific way to load my video
            I found a solution by adding an ID in the 'video' tag my button needed just this code to make it work

             

            var video = document.getElementById("myVideo");

            video.muted = !video.muted;

             

            thank you for your help

            • 3. Re: Video sound
              resdesign Adobe Community Professional & MVP

              Great. I was not sure how to help you since you failed to mention what version of Edge Animate you were using and what you setup was.

              Glad you found the solution.