2 Replies Latest reply on Feb 16, 2017 8:26 PM by johnrellis

    After Aperture Import Mac Lightroom Hangs for Minutes Between Clicks

    schalliol

      I have an iMac 5K (late 2015) 4GHz Quad Core i7, 24 GB RAM, 500 GB SSD running Sierra, Photoshop CC and Lightroom CC (all latest updates).  I tried to move from Aperture to Lightroom and used the import tool apparently successfully, and I let Lightroom move photos and asked it to build Smart Previews of all the files.  The photo library Lightroom uses is on the fastest single SSD I've ever seen in person.  The photos themselves are stored on a Synology DS 1515+ NAS (AFP over 802.11ac to gigabit Ethernet with great signal) with lots of available capacity and plenty of RAM.

       

      When I click between a folder of photos, it literally is non-responsive for many minutes (activity monitor acknowledges it's not responding and shows one core is maxed out) and then recovers with the photo or folder I want.  Since I had it build previews, I don't imagine there should be any lag because it should be retrieving the photos from the SSD.  I can transfer files pretty darn quickly to and from the NAS as well.  I tried to pull up the console to see if that would tell me anything about what's going on, and here is what I saw.  The first three console entries happened upon my click, so it was about 21:44:22 when I clicked on another folder of photos:

       

      default21:44:22.761192 -0500Adobe Lightroom[0x7feacb6f7c00] Decoding: C0 0x012C020D 0x0026354A 0x11111100 0x30108002 51786
      default21:44:22.761221 -0500Adobe Lightroom[0x7feacb6f7c00] Options: 300x525 [FFFFFFFF,FFFFFFFF] 0001C060
      default21:44:22.762403 -0500Adobe Lightroom[0x7feacb6f7c00] Decoding completed without errors
      default21:44:54.052869 -0500Adobe LightroomTIC TCP Conn Cancel [18475:0x61800138a010]
      default21:44:54.052997 -0500Adobe LightroomTIC TCP Conn Destroyed [18475:0x61800138a010]
      default21:44:54.053152 -0500Adobe Lightroom__nw_socket_service_writes_block_invoke sendmsg(fd 99, 31 bytes): socket has been closed
      ~7 minute gap
      default21:50:09.805911 -0500Adobe Lightroom[0x7fec4ad05600] Decoding: C0 0x04B00834 0x0096354A 0x11111100 0x00000000 624991
      default21:50:09.805942 -0500Adobe Lightroom[0x7fec4ad05600] Options: 1200x2100 [FFFFFFFF,FFFFFFFF] 0001D060
      default21:50:09.822044 -0500Adobe Lightroom[0x7fec4ad05600] Decoding completed without errors
      default21:50:10.242349 -0500Adobe Lightroom[0x7fecb18eca00] Created session
      default21:50:10.243070 -0500Adobe Lightroom[0x7fec9e234a00] Created session
      default21:50:10.247170 -0500Adobe Lightroom[0x7fecb18eca00] Decoding: C0 0x012C020D 0x0026354A 0x11111100 0x00000000 51786
      default21:50:10.247197 -0500Adobe Lightroom[0x7fecb18eca00] Options: 300x525 [FFFFFFFF,FFFFFFFF] 0001D060
      default21:50:10.248444 -0500Adobe Lightroom[0x7fecb18eca00] Decoding completed without errors
      default21:50:10.263940 -0500Adobe Lightroom[0x7fec9e234a00] Decoding: C0 0x04B00834 0x0096354A 0x11111100 0x00000000 624991
      default21:50:10.263964 -0500Adobe Lightroom[0x7fec9e234a00] Options: 1200x2100 [FFFFFFFF,FFFFFFFF] 0001D060
      default21:50:10.279402 -0500Adobe Lightroom[0x7fec9e234a00] Decoding completed without errors
      default21:50:10.348695 -0500Adobe Lightroom[0x7fec1c847000] Created session
      default21:50:10.349380 -0500Adobe Lightroom[0x7feb494d8000] Created session
      default21:50:10.349528 -0500Adobe Lightroom[0x7feb49561c00] Created session
      default21:50:10.349656 -0500Adobe Lightroom[0x7feb4943c400] Created session
      default21:50:10.349785 -0500Adobe Lightroom[0x7fec1cb6ae00] Created session
      default21:50:10.349908 -0500Adobe Lightroom[0x7fec1cc5c600] Created session
      default21:50:10.350035 -0500Adobe Lightroom[0x7feb49165400] Created session
      default21:50:10.350159 -0500Adobe Lightroom[0x7fec1cb91400] Created session
      default21:50:10.350280 -0500Adobe Lightroom[0x7feb493fee00] Created session
      default21:50:10.350402 -0500Adobe Lightroom[0x7feb492b2a00] Created session
      default21:50:10.350529 -0500Adobe Lightroom[0x7feb4940b400] Created session
      default21:50:10.350657 -0500Adobe Lightroom[0x7feb49371000] Created session
      default21:50:10.350780 -0500Adobe Lightroom[0x7feb49486e00] Created session
      default21:50:10.352539 -0500Adobe Lightroom[0x7feacb198400] Created session
      default21:50:10.382020 -0500Adobe LightroomUNIX error exception: 17
      default21:50:10.382133 -0500Adobe Lightroom0x6000cd67dbc0 opened /private/var/db/mds/system/mdsDirectory.db: 50744 bytes
      default21:50:10.382186 -0500Adobe Lightroom0x6000cd67dbc0 closed /private/var/db/mds/system/mdsDirectory.db
      default21:50:10.382352 -0500Adobe LightroomUNIX error exception: 17
      default21:50:10.382514 -0500Adobe Lightroom0x610049e78d80 opened /Users/schalliol/Library/Keychains/login.keychain-db: 571540 bytes
      default21:50:10.382764 -0500Adobe Lightroom0x610049e78d80 closed /Users/schalliol/Library/Keychains/login.keychain-db
      default21:50:10.385043 -0500Adobe Lightroomloading /Users/schalliol/Library/Keychains/login.keychain-db
      default21:50:10.387120 -0500Adobe Lightroom0x60800e461500 opened /Library/Keychains/System.keychain: 109900 bytes
      default21:50:10.387209 -0500Adobe Lightroom0x60800e461500 closed /Library/Keychains/System.keychain
      default21:50:10.389389 -0500Adobe Lightroomloading /Library/Keychains/System.keychain
      default21:50:10.392084 -0500Adobe LightroomTIC TCP Conn Start [18476:0x60000cf81fb0]
      default21:50:10.565456 -0500Adobe Lightroom[0x7fec1cae2400] Created session
      default21:50:10.572789 -0500Adobe Lightroom[0x7feca7a91000] Created session
      default21:50:10.573376 -0500Adobe Lightroom[0x7feb4e7e7800] Created session
      default21:50:10.601456 -0500Adobe Lightroom[0x7fe8ab887c00] Created session
      default21:50:10.602626 -0500Adobe Lightroom[0x7fe8b354fc00] Created session
      default21:50:10.668733 -0500Adobe Lightroom[0x7feacb46d600] Created session
      default21:50:10.668929 -0500Adobe Lightroom[0x7fec9ee7ec00] Created session
      default21:50:10.669063 -0500Adobe Lightroom[0x7feacb042a00] Created session
      default21:50:10.669188 -0500Adobe Lightroom[0x7fe8a9aa9200] Created session
      default21:50:10.669797 -0500Adobe Lightroom[0x7fec03a47000] Created session
      default21:50:10.685759 -0500Adobe Lightroom[0x7feacb797e00] Created session
      default21:50:10.685938 -0500Adobe Lightroom[0x7feacb455c00] Created session
      default21:50:10.686076 -0500Adobe Lightroom[0x7fec9ebfba00] Created session
      default21:50:10.686223 -0500Adobe Lightroom[0x7fec9efb6e00] Created session
      default21:50:10.686382 -0500Adobe Lightroom[0x7feacb23ac00] Created session
      default21:50:10.686504 -0500Adobe Lightroom[0x7feacb495e00] Created session
      default21:50:10.686634 -0500Adobe Lightroom[0x7feacb77d000] Created session
      default21:50:10.686823 -0500Adobe Lightroom[0x7fec9ebe1000] Created session
      default21:50:10.686952 -0500Adobe Lightroom[0x7fec9ec30e00] Created session
      default21:50:10.687080 -0500Adobe Lightroom[0x7feacb4c5400] Created session
      default21:50:10.687209 -0500Adobe Lightroom[0x7fec9ed72200] Created session
      default21:50:10.687759 -0500Adobe Lightroom[0x7feb4e6c2200] Created session
      default21:50:10.702409 -0500Adobe Lightroom[0x7feb49419e00] Created session
      default21:50:10.702588 -0500Adobe Lightroom[0x7feb49437a00] Created session
      default21:50:10.702724 -0500Adobe Lightroom[0x7feb49587200] Created session
      default21:50:10.702853 -0500Adobe Lightroom[0x7feb49047e00] Created session
      default21:50:10.702983 -0500Adobe Lightroom[0x7feb49795200] Created session
      default21:50:10.703106 -0500Adobe Lightroom[0x7feb490b2c00] Created session
      default21:50:10.703230 -0500Adobe Lightroom[0x7feb495fec00] Created session
      default21:50:10.711445 -0500Adobe LightroomTIC TCP Conn Event [18476:0x60000cf81fb0]: 1 Err(0)
      default21:50:10.711468 -0500Adobe LightroomTIC TCP Conn Connected [18476:0x60000cf81fb0]: Err(0)
      default21:50:10.711532 -0500Adobe LightroomTIC Enabling TLS [18476:0x60000cf81fb0]
      default21:50:10.748739 -0500Adobe LightroomTIC TLS Event [18476:0x60000cf81fb0]: 2, Pending(0)
      default21:50:10.749742 -0500Adobe LightroomTIC TLS Event [18476:0x60000cf81fb0]: 11, Pending(0)
      default21:50:10.750038 -0500Adobe LightroomTIC TLS Event [18476:0x60000cf81fb0]: 12, Pending(0)
      default21:50:10.750056 -0500Adobe LightroomTIC TLS Event [18476:0x60000cf81fb0]: 14, Pending(0)
      default21:50:10.772198 -0500Adobe LightroomTIC TLS Trust Result [18476:0x60000cf81fb0]: 0
      default21:50:11.065640 -0500Adobe LightroomTIC TLS Event [18476:0x60000cf81fb0]: 20, Pending(0)
      default21:50:11.065866 -0500Adobe LightroomTIC TCP Conn Event [18476:0x60000cf81fb0]: 8 Err(0)
      default21:50:11.065894 -0500Adobe LightroomTIC TLS Handshake Complete [18476:0x60000cf81fb0]

       

      Can anyone help me figure out what's going on?  Lightroom seems to be better than the last version of Aperture, but honestly it worked fine and I just didn't want to be lost.  I had CS 6 Photoshop I owned along with Aperture, but I thought I'd go ahead and try to stay a bit more current since Aperture hasn't been updated.  I'd love to hear if you can help me avoid trying to revert back to Aperture!  Thanks so much!!

        • 1. Re: After Aperture Import Mac Lightroom Hangs for Minutes Between Clicks
          johnrellis Most Valuable Participant

          asked it to build Smart Previews of all the files.

          Were smart previews still being built when you experienced this problem?  There would be a progress bar showing in the upper left corner, looking like this:

          or like this:

           

          depending on whether you had the top panel (the module picker) visible).

          • 2. Re: After Aperture Import Mac Lightroom Hangs for Minutes Between Clicks
            johnrellis Most Valuable Participant

            asked it to build Smart Previews of all the files. ... Since I had it build previews, I don't imagine there should be any lag because it should be retrieving the photos from the SSD.

            Note that there is a difference between "previews" and "smart previews". 

             

            The Library module uses "previews" to display the thumbnails in grid view and to display single photos in loupe mode.  When you import photos, LR will build previews in background, with the progress bar in the upper-left corner showing the progress.   I recall just a couple reports in the past of LR not being very usable while it builds previews, though your symptoms sound extreme.

             

            "Smart previews" are only used by Develop, not Library. They allow you to edit in Develop while the photos are offline (e.g. when you're on a laptop that doesn't have access to the volume with the photos), and there's an option (off by default) for Develop to always use smart previews instead of the original photos (which speeds up Develop for many but not all people).

             

            Some questions:

             

            1. After rebooting your computer and restarting LR, is it still using CPU according to Activity Monitor? 

             

            2. Does LR still misbehave after rebooting?

             

            3. About how many photos did you import from Aperture into your LR catalog?