8 Replies Latest reply on Mar 1, 2017 7:04 AM by WolfShade

    Button

    siti nabihah93

      Hi.. I'm new to cold fusion and still in process of the learning cold fusion.

       

      I have a problem in create a button for update..i've use all kind of tag such us <a>, <input> and <button> but still it didn't work..

       

      this is the result when i run the coding..anyone have a solution?

      1.PNG

        • 1. Re: Button
          haxtbh Level 4

          What is the actual code? What ever the content is you are entering here is just a string not HTML.

           

          Without seeing how you are producing this though or what the code is, its impossible to tell. Could just simply be malformed HTML in the rest of it.

          • 2. Re: Button
            siti nabihah93 Level 1

            3.PNG

             

            this is my code..if i remove the tag output the result is still the same..

            • 3. Re: Button
              bloodbanker Level 1

              Try this instead of <button...

              <input type="Submit" name="Submit" value="Pilih " />

              • 4. Re: Button
                haxtbh Level 4

                Are you using another library on the table. I notice you have sorting etc, this library you are using might be stopping the cells from using html.

                • 5. Re: Button
                  WolfShade Level 4

                  Is the HTML hard-coded by you?  As haxtbh pointed out, there could be a JavaScript library that is affecting the TDs.  Since the code is hard-coded and not pulled from a third source, I feel like this is being affected by something else.  If you "View Source" the section where the button is supposed to be, does the TD value start with &lt; or other encoded representation for '<'?

                   

                  HTH,

                   

                  ^_^

                  • 6. Re: Button
                    siti nabihah93 Level 1

                    i have attribute data-toggle for my table..that's why the result is like that..if i remove the attributes the button will be there..but can i still have the attributes and make the button there?

                    • 7. Re: Button
                      haxtbh Level 4

                      The question still stands, which third party library are you using?? You must be using another javascript plugin to make the table do this. What ever it is, is making the cells force to a string so that they can be correctly sorted. This is probably explained in the documentation of the plugin you are using.

                      • 8. Re: Button
                        WolfShade Level 4

                        One thing that I would suggest is to apply a class name to the TDs that you want that third party plugin to 'convert', then use JavaScript to apply the plugin only to those TDs, leaving the TD containing the button alone.

                         

                        This is, of course, me assuming that you are currently applying the plugin to all TDs.  If this is not the case, then we need more information.  Like (as haxtbh pointed out) what third party library or plugin you're using.

                         

                        V/r,

                         

                        ^_^