0 Replies Latest reply on Mar 16, 2017 12:49 AM by joew22881743

    About edge server to origin server via RTMPS.

    joew22881743 Level 1

      Hi all,

      I am trying to setup edge server with RTMPS protocol.

      I am follow below link to setup edge and origin server.

      https://helpx.adobe.com/adobe-media-server/config-admin/configuring-security-features.html

      I can connect directly to the origin server via RTMPS.

      But when I want to connect to the origin server through the edge server via RTMPS. I got a error message below.

      2017-03-06      15:55:23        27109   (i)2581223      Core (27654) is no longer active.
      2017-03-06      15:55:23        27109   (w)2581256      Core (27654) _defaultRoot_:_defaultVHost_:::_0 experienced 1 failure[s]!
      

       

      May I missing some setting?

      AMS version: AMS_5_0_6_r6102

      Below is my setting.

       

      origin-server/ams.ini

      ADAPTOR.HOSTPORT = :1935,-443
      

       

      origin-server/Server.xml

      <SSL>
        <SSLRandomSeed>16</SSLRandomSeed>
        <SSLSessionCacheGC>5</SSLSessionCacheGC>
        <SSLClientCtx>
        <SSLVerifyCertificate>true</SSLVerifyCertificate>
        <SSLCACertificatePath></SSLCACertificatePath>
        <SSLCACertificateFile>/opt/adobe/ssl/gd_bundle-g2-g1.crt</SSLCACertificateFile>
        <SSLVerifyDepth>9</SSLVerifyDepth>
        <SSLCipherSuite>ALL:!ADH:!LOW:!EXP:!MD5:@STRENGTH</SSLCipherSuite>
        </SSLClientCtx>
      </SSL>
      

       

      origin-server/_defaultRoot_/Adaptor.xml

      <SSL>
        <SSLServerCtx>
        <SSLCertificateFile>/opt/adobe/ssl/my_domain.crt</SSLCertificateFile>
        <SSLCertificateKeyFile type="PEM">/opt/adobe/ssl/my_private.key</SSLCertificateKeyFile>
        <SSLPassPhrase></SSLPassPhrase>
        <SSLCipherSuite>ALL:!ADH:!LOW:!EXP:!MD5:@STRENGTH</SSLCipherSuite>
        <SSLSessionTimeout>5</SSLSessionTimeout>
        <SSLVerifyClient log="false">none</SSLVerifyClient>
        <SSLVerifyDepth>9</SSLVerifyDepth>
        </SSLServerCtx>
      </SSL>
      

       

      edge-server/ams.ini

      ADAPTOR.HOSTPORT = :1935,-443
      

       

      edge-server/Server.xml

      <SSL>
        <SSLRandomSeed>16</SSLRandomSeed>
        <SSLSessionCacheGC>5</SSLSessionCacheGC>
        <SSLClientCtx>
        <SSLVerifyCertificate>true</SSLVerifyCertificate>
        <SSLCACertificatePath></SSLCACertificatePath>
        <SSLCACertificateFile>/opt/adobe/ssl/gd_bundle-g2-g1.crt</SSLCACertificateFile>
        <SSLVerifyDepth>9</SSLVerifyDepth>
        <SSLCipherSuite>ALL:!ADH:!LOW:!EXP:!MD5:@STRENGTH</SSLCipherSuite>
        </SSLClientCtx>
      </SSL>
      

       

      edge-server/_defaultRoot_/Adaptor.xml

      <SSL>
        <SSLServerCtx>
        <SSLCertificateFile>/opt/adobe/ssl/my_domain.crt</SSLCertificateFile>
        <SSLCertificateKeyFile type="PEM">/opt/adobe/ssl/my_private.key</SSLCertificateKeyFile>
        <SSLPassPhrase></SSLPassPhrase>
        <SSLCipherSuite>ALL:!ADH:!LOW:!EXP:!MD5:@STRENGTH</SSLCipherSuite>
        <SSLSessionTimeout>5</SSLSessionTimeout>
        <SSLVerifyClient log="false">none</SSLVerifyClient>
        <SSLVerifyDepth>9</SSLVerifyDepth>
        </SSLServerCtx>
      </SSL>
      

       

      edge-server/_defaultRoot_/_defaultVHost_/Vhost.xml

      <Proxy>
        <Mode>remote</Mode>
        <RequestTimeout>2</RequestTimeout>
        <Anonymous>false</Anonymous>
        <CacheDir enabled="false" useAppName="true">
        <Path></Path>
        <MaxSize>32</MaxSize>
        </CacheDir>
        <LocalAddress></LocalAddress>
        <RouteTable protocol="rtmps">
        <RouteEntry>*:*;origin.mydomain.com:443</RouteEntry>
        </RouteTable>
        <EdgeAutoDiscovery>
        <Enabled>false</Enabled>
        <AllowOverride>true</AllowOverride>
        <WaitTime>1000</WaitTime>
        </EdgeAutoDiscovery>
        <SSL>
        <SSLVerifyCertificate>true</SSLVerifyCertificate>
        <SSLCACertificatePath></SSLCACertificatePath>
        <SSLCACertificateFile>/opt/adobe/ssl/gd_bundle-g2-g1.crt</SSLCACertificateFile>
        <SSLVerifyDepth>9</SSLVerifyDepth>
        <SSLCipherSuite>ALL:!ADH:!LOW:!EXP:!MD5:@STRENGTH</SSLCipherSuite>
        </SSL>
        <AggregateMessages enabled="true">
        </AggregateMessages>
      </Proxy>
      

       

      edge-server/core.00.log

      #Fields: date   time    x-pid   x-status        x-ctx   x-comment
      2017-03-13      14:42:41        9384    (i)2581237      Starting admin app on core (9384).      -
      2017-03-13      14:42:41        9384    (i)2581238      Core (9384) connecting to admin.        -
      2017-03-13      14:42:41        9384    (i)2581231      Core (9384) connected to admin. -
      2017-03-13      14:42:41        9384    (i)2581234      Core (9384) connection to admin accepted.       -
      2017-03-13      14:42:41        9384    (i)2631174      Listener started ( _defaultRoot_ ) : 127.0.0.1:19351 (rtmfp-core)/v4    -
      2017-03-13      14:42:41        9384    (i)2631174      Listener started ( _defaultRoot_ ) : 192.168.10.132:19351 (rtmfp-core)/v4       -
      2017-03-13      14:42:41        9384    (i)2631509      Public rtmfp-core addresses for listener _defaultRoot_ are: 127.0.0.1:19351;192.168.10.132:19351        -
      2017-03-13      14:42:41        9384    (i)2581246      Core (9384) sending register cmd to edge.       -
      

       

      edge-server/edge.00.log

      #Fields: date   time    x-pid   x-status        x-ctx   x-comment
      2017-03-13      14:42:28        8926    (i)2581173      AMS detected IPv6 protocol stack!       -
      2017-03-13      14:42:28        8926    (i)2581173      AMS config <NetworkingIPv6 enable=false>        -
      2017-03-13      14:42:28        8926    (i)2581173      AMS running in IPv4 protocol stack mode!        -
      2017-03-13      14:42:28        8926    (i)2581173      Host: localhost.localdomain IPv4: 192.168.10.132        -
      2017-03-13      14:42:28        8926    (i)2631174      Listener started ( _defaultRoot__edge1 ) : localhost:19350/v4   -
      2017-03-13      14:42:29        8926    (i)2631174      Listener started ( _defaultRoot__edge1 ) : 443 (secure)/v4      -
      2017-03-13      14:42:29        8926    (i)2631174      Listener started ( _defaultRoot__edge1 ) : 1935/v4      -
      2017-03-13      14:42:30        8926    (i)2631174      Listener started ( _defaultRoot__edge1 ) : 127.0.0.1:19350 (rtmfp-core)/v4      -
      2017-03-13      14:42:30        8926    (i)2631174      Listener started ( _defaultRoot__edge1 ) : 192.168.10.132:19350 (rtmfp-core)/v4 -
      2017-03-13      14:42:30        8926    (i)2631509      Public rtmfp-core addresses for listener _defaultRoot__edge1 are: 127.0.0.1:19350;192.168.10.132:19350  -
      2017-03-13      14:42:30        8926    (i)2631174      Listener started ( _defaultRoot__edge1 ) : 127.0.0.1:1935 (rtmfp)/v4    -
      2017-03-13      14:42:30        8926    (i)2631174      Listener started ( _defaultRoot__edge1 ) : 192.168.10.132:1935 (rtmfp)/v4       -
      2017-03-13      14:42:30        8926    (i)2631174      Listener started ( _defaultRoot__edge1 ) : 127.0.0.1:443 (rtmfp)/v4     -
      2017-03-13      14:42:30        8926    (i)2631174      Listener started ( _defaultRoot__edge1 ) : 192.168.10.132:443 (rtmfp)/v4        -
      2017-03-13      14:42:40        8926    (i)2581252      Registering core (9213).        -
      2017-03-13      14:42:40        8926    (i)2581250      Edge disconnected from core (9213).     -
      2017-03-13      14:42:41        8926    (i)2581252      Registering core (9384).        -
      2017-03-13      14:42:41        8926    (i)2581250      Edge disconnected from core (9384).     -
      

       

      edge-server/master.00.log

      #Fields: date   time    x-pid   x-status        x-ctx   x-comment^M
      2017-03-13      14:42:27        8900    (i)2581173      AMS detected IPv6 protocol stack!       
      2017-03-13      14:42:27        8900    (i)2581173      AMS config <NetworkingIPv6 enable=false>        
      2017-03-13      14:42:27        8900    (i)2581173      AMS running in IPv4 protocol stack mode!        
      2017-03-13      14:42:27        8900    (i)2581173      Host: localhost.localdomain IPv4: 192.168.10.132        
      2017-03-13      14:42:27        8900    (i)2571011      Server starting...      
      2017-03-13      14:42:28        8900    (i)2581413      /opt/adobe/ams/Apache2.2/bin/httpd -f ./conf/httpd.conf -d "/opt/adobe/ams/Apache2.2" -k start returned 0: [Mon Mar 13 14:42:27 2017] [info] mod_jithttp - AMS installation path: "/opt/adobe/ams/"
      httpd: Could not reliably determine the server's fully qualified domain name, using localhost.localdomain for ServerName        
      2017-03-13      14:42:28        8900    (i)2581413      /opt/adobe/ams/Apache2.2/bin/htcacheclean -n -t -i -p/opt/adobe/ams/Apache2.2/cacheroot -d5 -l1024K returned 0:         
      2017-03-13      14:42:28        8900    (i)2581224      Edge (8926) started, arguments : -edgeports ":1935,-443" -coreports "localhost:19350" -conf "/opt/adobe/ams/conf/Server.xml" -adaptor "_defaultRoot_" -name "_defaultRoot__edge1" -edgename "edge1".    
      2017-03-13      14:42:28        8900    (i)2571111      Server started (/opt/adobe/ams/conf/Server.xml).        
      2017-03-13      14:42:40        8900    (i)2581221      Core (9213) started, arguments : -adaptor "_defaultRoot_" -vhost "_defaultVHost_" -app  -inst  -tag "_0" -conf "/opt/adobe/ams/conf/Server.xml" -name "_defaultRoot_:_defaultVHost_:::_0".      
      2017-03-13      14:42:41        8900    (i)2581223      Core (9213) is no longer active.        
      2017-03-13      14:42:41        8900    (w)2581256      Core (9213) _defaultRoot_:_defaultVHost_:::_0 experienced 1 failure[s]! 
      2017-03-13      14:42:41        8900    (i)2581221      Core (9384) started, arguments : -adaptor "_defaultRoot_" -vhost "_defaultVHost_" -app  -inst  -tag "_0" -conf "/opt/adobe/ams/conf/Server.xml" -name "_defaultRoot_:_defaultVHost_:::_0".      
      2017-03-13      14:42:43        8900    (i)2581223      Core (9213) is no longer active.        
      2017-03-13      14:42:43        8900    (i)2581223      Core (9384) is no longer active.        
      2017-03-13      14:42:43        8900    (w)2581256      Core (9384) _defaultRoot_:_defaultVHost_:::_0 experienced 1 failure[s]!