6 Replies Latest reply on Mar 7, 2017 4:23 PM by coder1957**

    CF2016 new install - Service unavailable

    coder1957** Level 1

      Just installed 2016 on a test server ... it had 10 before.

      After install, brought up Admin panel ... it did its thing.

      But all I get is an error below.

       

      Checked for CFIDE and jakarta ... usual mapping.  They were gone.

      Added their directories in Windows IIS.

      Made sure CF10 shut down, 2016 running. yes.

       

      Ok, what am I missing?

       

       

      The service is unavailable.

      Service Temporary Unavailable!

      The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.





        Jakarta/ISAPI/isapi_redirector/1.2.32 ()


      Copyright © 1999-2011 Apache Software Foundation
      All Rights Reserved

        • 1. Re: CF2016 new install - Service unavailable
          carl type3 Level 4

          Hi,

           

          Perhaps check IIS web site ISAPI filter setting for where tomcat is being directed.

           

          EG

          Capture.JPG

           

           

           

           

          HTH, Carl.

          • 2. Re: CF2016 new install - Service unavailable
            coder1957** Level 1

            Ha ... hah!

             

            That fixed that error ... now I just get a 500 Error.

            Course it could be related ... I pointed Tomcat to

            /coldfusion2016/config/wsconfig/cfwin32.dll

             

            So close?

            • 3. Re: CF2016 new install - Service unavailable
              carl type3 Level 4

              So close yet far.

               

              Perhaps with ISAPI tomcat setting pointing to correct DLL restart IIS since it was pointing to wrong DLL.

               

              Details in ColdFusion2016\config\wsconfig\1\isapi_redirect.log might be interesting to diagnose further.

               

              Regards, Carl.

              • 4. Re: CF2016 new install - Service unavailable
                coder1957** Level 1

                This does not exist

                 

                ColdFusion2016\config\wsconfig\1\isapi_redirect.log

                specifically under CF10/cf11 where there is a /1/  in the path, there isn't in 2016.

                 

                And the only log files that DO exist under "16"/wsconfig/ are

                wsconfig.log

                Which contains

                 

                # Created by ColdFusion on 03/07 11:31:18

                03/07 11:31:18 info Tomcat Connector

                03/07 11:31:20 debug command line: -ws IIS -site 0 -enableBuffering -connectionPoolSize 500 -connectionPoolTimeout 60 -reuseConnectionCount 250 -v

                03/07 11:31:22 error This web server is already configured by some other version of ColdFusion.

                com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstallerException: This web server is already configured by some other version of ColdFusion.

                  at com.adobe.coldfusion.connector.connectorinstaller.IISInstaller.installConnector(IISInstal ler.java:219)

                  at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.installConnector(Con nectorInstaller.java:432)

                  at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.doIt(ConnectorInstal ler.java:372)

                  at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.main(ConnectorInstal ler.java:887)

                 

                03/07 13:41:43 info Tomcat Connector

                03/07 13:42:14 info Tomcat Connector

                 

                But that was hours ago ... the timestamp is CT.

                ===================

                Then I created a simple.html file which has only a table and td and hello world.

                It just stayed at 500 Internal Error.

                 

                Renamed application.cfm to application_iis.cfm

                 

                Still the same.

                 

                Every time I upgrade CF (like every 2 years) I get this; why cannot Adobe do a BETTER job at making the installer a little smarter?

                 

                It saw CF10 in there ... so work with it and it migrated all those settings.

                • 5. Re: CF2016 new install - Service unavailable
                  carl type3 Level 4

                  Perhaps run ColdFusion2016\cfusion\runtime\bin\wsconfig as administrator.

                   

                  Should look like tho "All" may differ to an IIS site EG:

                   

                  Capture.JPG

                   

                  I am not an Adobe CF staffer so not my place to comment on BETTER.

                   

                  Regards, Carl.

                  • 6. Re: CF2016 new install - Service unavailable
                    coder1957** Level 1

                    Thanks.   That was the first thing I did.

                     

                    Besides, they could've made 2016 WSC look different! 

                     

                    Tried that AGAIn and it did add a cf_script to something but still nada,

                     

                    May have to call "support"

                    Thanks for your efforts.