10 Replies Latest reply on Mar 8, 2017 11:04 AM by Bob Somrak

    LR6.9 crashed my OS 10.9.5

    zazzo5 Level 1

      i was notified of an available upgrade for my version of LR 6.8 i believe.. it did not install with a error code of U44M1P7.. i have purchased every release of LR since it's inception and now i'm unable to launch it.. really upsetting.. i need a working version of LR NOW..TODAY