10 Replies Latest reply on Mar 15, 2017 6:08 PM by cristphoto1

    Lightroom 5.7 with Canon EOS 5D Mark IV

    carenc27493191 Level 1

      I am using Lightroom 5.7 and I can't see my pictures from my new Canon. Do I need Lightroom 6? In the description it is said, that it is not necessary to by a new version it is just necessary to update the converter? Thanx

      kind regards, caren