1 Reply Latest reply on Mar 11, 2017 4:58 PM by ManiacJoe

    Performance of Lightroom CC on Microsoft Surface Book

    Rivor

      I purchased the Surface Book for the principal reason to use it for processing my photographic images with Lightroom and sometimes Photoshop. At the time I had people assuring me that this would be a great device for my requirement and better than a Mac Book. Instead, it has been a huge disappointment and I believe a big expensive mistake to have moved away from the Apple platform. I have had the Surface now for seven months, expecting that I would become more satisfied with as I gained experience with the new platform, but no, it is still awful. I have run searches and found only one mention of this issue from back in July 2016. I find it difficult to wade through the responses there and filter out information that is directly relevant to and useful for understanding what is the issue. That I found no other questions on this matter suggests to me that it is not a common problem.

       

      So, I have a Surface Book, i7 core processor, 2.81 GHz with 8GB memory. It has GeForce GPU NVIDIA 3.3.0. Runs with Windows 10.0.

      I am using Lightroom CC 2015.9.

       

      Are there know issues about poor performance of Adobe Lightroom when running on the Surface Book? Are there ready remedies for any such poor performance issues? What might I do so as to achieve performance improvements to bring the use of Lightroom on my Surface Book to a more acceptable level?

        • 1. Re: Performance of Lightroom CC on Microsoft Surface Book
          ManiacJoe Adobe Community Professional

          Most likely it is the 8 gig of memory that is killing you. 8gig is the bare essentials, you really want 16 gig or more.

           

          Check the number of CPU cores running on the Surface. If it has more than 4 cores, there have been some reports that say LR may actually run faster when restricted to only 4 cores in some cases.

           

          If you have the GPU optimization turned on, try turning it off (menu: edit / preferences / performance) and see if that helps.

           

          Other than that, describe your performance problems in great detail and we will see what we can do for you.