1 Reply Latest reply on Mar 13, 2017 1:21 AM by gener7

    Could not complete your request because the file is not compatible with this version of Photoshop.

    nathang59672027

      I am having this problem as well. A psd that was made in the version of photoshop I am using no longer 'is compatible' with my version of of photoshop(the same version it was made in) Adobe CC 2017 ).