1 Reply Latest reply on Mar 26, 2017 11:06 AM by jenshp

    MSVCR80.dll: Photoshop CS4 (and 64 bit), Bridge CS4 RAW settings don't start

    jenshp

      Dear All,

       

      After years of using Photoshop CS4, latest version, on my Windows 7 Professional N 64 bit system I suddenly cannot use it any more. This started a few weeks ago and from this moment in time, it was not possible for me to solve it. Now, I am hoping somebody has the helping idea

       

      Situation: Starting Photoshop (64 bit), nothing visible for several seconds and then the windows error message pops up. There, the MSVCR80.dll file is mentioned as the error module.

      The same happens for the x86 version of Photoshop. But even more strange: Starting adobe Bridge CS4, there is no error at all. BUT, once I want to open the Camera RAW settings or open the adobe Updater, the same error occurs in Bridge CS4!

       

      My system:

      Windows 7 Professional N (AMD 64) (all updates which are available are installed) on a SSD hard disc drive (HDD)

      Intel i5-2500 Processor

      16 GB RAM

      GeForce 7900 GS

       

      What did I do solve it?

      Reinstalled,

      Deleted the NIK filter package,

      Removed all C++ libraries,

      Installed it on another HDD,

      Used the installer file from adobe,

      Started the program unregistered (without Key),

      Started the program after the update to the latest version,

      Used different Windows users,

      Cleaned up Windows update setupfiles and configuration,

      Put the "MSVCR80.dll" in the suggested adobe Photoshop folder...

       

      I am really sorry that I cannot recall the order, but I tried already a lot of combinations, of course not all possible once yet . And especially, it takes all a lot of time and it still doesn't work; even though, before this moment in time it worked perfectly. Almost never a crash of the application.

       

      What else can I do? I hope there are more solutions than reinstalling Windows.

       

      Warm regards,

      Jens

       

      *3rd UPDATE*

      After some searching I narrowed it down to the winsxs folder, where this mysterious file is located. I found out that all files are belonging to "TrustedInstaller". Once you know how to change the ownership to the admin, it is possible to play with these files. In the end, I found the folder, with the specific "MSVCR80.dll" file.

       

      Ok, renamed and zack, Photoshop was not able to find this file any more. From this moment I thought there is nothing more to do as to copy different files into this folder, but this didn't work either.

       

      To solve this problem, I have to know, which of the Microsoft Visual C++ 2005 version is required. And there are a lot. For the moment I am experimenting with

      vcredist_x64 - 8.0.50727.42 (Seems to be linked somewhere in the adobe registry, because acrobat is also looking for it. Via

      Update for Visual C++ 2005 SP1 Redistributable Package if found that there are a kind of subsubsub-versions; all in the winsxs folder. Here

      Avoiding problems with VC2005 SP1 Security update KB971090 | Ted's Blog

      someone explains how to code it in a software to use a specific one. I wish I would know, what is written in CS4....)

      vcredist_x64 - 8.0.56336

      vcredist_x64 - 8.0.56336 -SP1

      vcredist_x64 - 8.0.61000    <--- Based on my knowledge the latest version (17-May-2011), available via Download Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package MFC Security Update from Official Microsoft Do… NOT install immediately, since it might harm your adobe settings as well

       

      Does anybody knows, how many versions are existing and what is the latest? If not, which version do you have with a working CS4?

       

      After a lot of tests and different installations: According to Windows 7 programs, I am using the "latest" version of the Microsoft Visual C++ 2005 libraries. On MY pc, this file can be found:

      Ref. 1: C:\Windows\winsxs\amd64_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.6195_none_88e41e092fab0294

      For the x86 library: C:\Windows\winsxs\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.6195_none_d09154e0442 72b9a

      As a test, I installed an old adobe software, in this case acrobat 8.0, with the result that another "MSVCR80.dll" file, inclusive folder was created:

      Ref. 2: C:\Windows\winsxs\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.163_none_10b3ea459bfe e365

      but still NO installation in the windows 7 program manager!

       

      Finally I installed Photoshop CS4 and the latest update, again, and, another "MSVCR80.dll" file + folder was created

      Ref. 3: C:\Windows\winsxs\amd64_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.762_none_c905be8887838ff2

      and again no installation in the windows 7 program manager!

       

      Once I started Photoshop, I had the same error, as in the beginning. No start at all. Via the Windows Event Viewer, I saw that the path to the error file / module / library was pointing to Ref. 1! Because of this, I understood a bit more of the error message. There, the Error Module Version "8.0.50727.6195" was mentioned. This is the file from Ref. 1.

       

      My assumption is, that somewhere in the Windows Registry I have to change the path from Ref. 1 to Ref. 3. Let's, if I am able to do this.....

       

       

      *Keep you updated!*

       

      Changed to capture the latest information and hopefully help other people.

       

      Updated for those who can deeper then me

       

      Added Microsoft Visual C++ 2005 version and path findings