6 Replies Latest reply on Mar 21, 2017 11:34 AM by ryanskihead

    Iframe embedding issues

    miker29228625

      Really stuck here, probably due to my own inexperience.

      Using Phonegap Build to compile a very simple app on IOS & Android.

      Have permission from the source, the Iframe loads in the app, but does not function correctly, divs inside the iframe do not open, the script does not run properly, -as in you can not click the links - this works in a browser like ios safari, but not in app. You can highlight only, when testing in app browser instead of iframe, same event - failed to load. Feel like it's an access issue.

      Here is the relevant plugins and rules for config.xml (using cli-6.5.0 and have tried previous versions)

      <plugin name="cordova-plugin-inappbrowser" /> <plugin name="cordova-plugin-whitelist" /> <access origin="*"/> <allow-navigation href="*" /> <allow-navigation href="*/*" /> <allow-navigation href="http://*/*" /> <allow-navigation href="https://*/*" /> <allow-navigation href="data:*" /> <allow-intent href="http://*/*" /> <allow-intent href="https://*/*" /> <allow-intent href="*" /> <allow-intent href="http://*/*" /> <allow-intent href="https://*/*" /> <allow-intent href="*" />

      And here is the basic html

      <iframe src="https://widget.treatwell.co.uk/place/#venue-menu-page?id=310342"> </iframe>

       

       

      I'm not sure what this is, but think it might be something to do with permission, or cookie session timeout??

      Any help what so ever appreciated.