4 Replies Latest reply on Aug 25, 2008 9:25 PM by cesaregb

    Problem with bin-release

    cesaregb
      Hi All I've a problem

      I have a httpservice in my little and small aplicaton, this works perfect when i run it inside of the IDE of flex the problem comes when i try to export it ... i press file and export- release build... and everithing seams to work but when i use the swf file of the bin release, i dont know why i keep getting an error on the httpservice this return me a error

      this is the code that this give me

      [RPC Fault faultString="Security error accessing url" faultCode="Channel.Security.Error" faultDetail="Destination: DefaultHTTP"]
      at mx.rpc::AbstractInvoker/ http://www.adobe.com/2006/flex/mx/internal::faultHandler()
      at mx.rpc::Responder/fault()
      at mx.rpc::AsyncRequest/fault()
      at DirectHTTPMessageResponder/securityErrorHandler()
      at flash.events::EventDispatcher/dispatchEventFunction()
      at flash.events::EventDispatcher/dispatchEvent()
      at flash.net::URLLoader/redirectEvent()

      and i use the swf file like this

      <script type="text/javascript">
      AC_FL_RunContent( 'codebase',' http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','wid th','740','height','280','title','s','src','searchProd01','quality','high','pluginspage',' http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','movi e','searchProd01' ); //end AC code
      </script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase=" http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="740" height="280" title="s">
      <param name="movie" value="searchProd01.swf" />
      <param name="quality" value="high" />
      <embed src="searchProd01.swf" quality="high" pluginspage=" http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="740" height="280"></embed>
      </object></noscript>

      if any of you can tell me what can be this error maybe im using in the wrong way the bin release folder, how should i use it ?? or any idea ??

      well i hope someone can giveme a little of help
      best regards
      Cesar
        • 1. Re: Problem with bin-release
          batmitra
          hi
          just a few thougts:

          are you trying to acces an httpservice outside your domain?
          how are you handlinh your httpservice calls?

          the questions i'm putting here is because thar error messafe you are receiving probably has to do with sandbox security violation, so you should see if there is an crossdomain.xml file on the server you are trying to access.
          • 2. Re: Problem with bin-release
            Level 7

            "cesaregb" <webforumsuser@macromedia.com> wrote in message
            news:g8qu8l$2fv$1@forums.macromedia.com...
            > Hi All I've a problem
            >
            > I have a httpservice in my little and small aplicaton, this works perfect
            > when
            > i run it inside of the IDE of flex the problem comes when i try to export
            > it
            > ... i press file and export- release build... and everithing seams to
            > work but
            > when i use the swf file of the bin release, i dont know why i keep getting
            > an
            > error on the httpservice this return me a error
            >
            > this is the code that this give me
            >
            > [RPC Fault faultString="Security error accessing url"
            > faultCode="Channel.Security.Error" faultDetail="Destination: DefaultHTTP"]
            > at
            > mx.rpc::AbstractInvoker/ http://www.adobe.com/2006/flex/mx/internal::faultHandler
            > ()
            > at mx.rpc::Responder/fault()
            > at mx.rpc::AsyncRequest/fault()
            > at DirectHTTPMessageResponder/securityErrorHandler()
            > at flash.events::EventDispatcher/dispatchEventFunction()
            > at flash.events::EventDispatcher/dispatchEvent()
            > at flash.net::URLLoader/redirectEvent()
            >
            > and i use the swf file like this
            >
            > <script type="text/javascript">
            > AC_FL_RunContent(
            > 'codebase',' http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#
            > version=9,0,28,0','width','740','height','280','title','s','src','searchProd01',
            > 'quality','high','pluginspage',' http://www.adobe.com/shockwave/download/download
            > .cgi?P1_Prod_Version=ShockwaveFlash','movie','searchProd01' ); //end AC
            > code
            > </script><noscript><object
            > classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
            > codebase=" http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#ve
            > rsion=9,0,28,0" width="740" height="280" title="s">
            > <param name="movie" value="searchProd01.swf" />
            > <param name="quality" value="high" />
            > <embed src="searchProd01.swf" quality="high"
            > pluginspage=" http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Versio
            > n=ShockwaveFlash" type="application/x-shockwave-flash" width="740"
            > height="280"></embed>
            > </object></noscript>

            Are you testing locally or from the server? I think when you publish a
            release version, Flex automatically flips the switch that tells the swf it
            is a server.

            HTH;

            Amy


            • 3. Re: Problem with bin-release
              cesaregb Level 1
              Hi, i havent any handle function for the httpservice i just assign the result to a datagrid, and i do have the cross domain i think this one works because when i debug it does work and when i didn't have it this doesn't works

              my cross domain its temporally like this

              <cross-domain-policy>
              <allow-access-from domain="*" />
              </cross-domain-policy>

              also i add a question in here this will be .. how can i add a domain in here this would be like " <allow-access-from domain=" http://www.mydomain.com" />" ??

              and tea im testing this in local way i've the iis and im adding this swf file in one of the pages and i test it by http://localhost/mypage.html
              this have something to do ??


              what else can i do ??


              regards
              Cesar
              • 4. Re: Problem with bin-release
                cesaregb Level 1
                hi

                i already upload the file and still doens't working

                http://www.sotoautopartes.com/page/products.html this is the page if any of you can help me i starting to lost my mind

                it's so rear why when I press the play button does work what is the difference in this


                well I hope anyone can help me best regards

                Cesar