3 Replies Latest reply on Aug 27, 2008 8:16 AM by html.mencken

    Air App: "kuler klash" and invalid ID or password (bug?)

    html.mencken Level 1
      Hello, I have trouble signing into kuler from the air app; when I enter my username (i.e. email address, unfortunately) and password, I always get the "invalid ID or password" response.

      I have never been able to sign in via Air by the way. Additionally, I now see "kuler klash. Please try again later" at the top and can't use the Air app at all. I don't have any of these problems when I sign in via the web site.

      Re. the "klash" neologism: What happens when kulers.. uhm.. klash? Do I need to take care when using the air app and the web site at the same time? That is to say, is the Air app getting confused if I sign into kuler in both places at the same time or within a short time period?
        • 1. Re: Air App: "kuler klash" and invalid ID or password
          Sami@Adobe Adobe Employee
          Hmm... I'm not sure what's going on. Just in case, can you check what version of the Kuler desktop you are running? If you hover over a theme, does the cursor become a hand, and is the "ku" logo cut out from the upper left corner?
          Re: klashing should not be an issue. You should be able to run both website and AIR app, that's what I usually do.
          Sami
          • 2. Re: Air App: "kuler klash" and invalid ID or password
            html.mencken Level 1
            How do find the version number Sami? It seems I have two separate issues right now, an error that causes the "kuler klash" message and the signing in issue - which I've seen since I installed the app. Right now, the app does not initialize - I just see a blank window so I can't roll the mouse over any colors. The logo is cut out from the dashboard though, if that helps with identifying the version I am running. I assume Air updates itself in the background, currently v1.1 on my machine I think. Is there a way to reset the kuler app from the command line? Otherwise I'll try re-installing and let you know if that helps.
            • 3. Re: Air App: "kuler klash" and invalid ID or password
              html.mencken Level 1
              Ok, I solved it and I think I found a bug with the current version of the kuler Air app: I uninstalled and re-installed from the product page. After that, and before entering my credentials, I still had the same double error message. Then I tried to copy - paste my login credentials into the respective fields and noticed that kuler accepted the paste operation twice in each entry field. That is, instead of seeing

              username: email
              password: abcd


              I saw:

              username: emailemail
              password: abcdabcd


              Next I tried typing my credentials into the 2 fields and it worked.

              Looks like a bug to me :-) It should be trivial to reproduce this: instead of typing in your username and password, just copy and paste them into the respective fields and note that the paste operation results in a double-length/appended string ("pastepaste").

              This would also explain why I had problems before: earlier, I had typed in the username part but then I used copy-paste for the password. Because the password field is being obscured by stars, I did not notice that the kuler app was accepting my pasted password twice (and failed to authenticate as a result).



              Note: As far as I can see, kuler won't tell you its version number even during the installation process - you'll have to download and install it again to "find out" if you are in fact running the latest version or not. The same goes for the Air framework itself - there is no way, or no easy way at least, to tell what version of Air you are running as it's running in the background. I think Air should have it's own notification tray (on Vista or Gnome/KDE or OS X) / systray (on XP) icon so that you can tell when it's running, and what version etc.