2 Replies Latest reply on Mar 25, 2017 10:49 PM by bvz2000

    One specific sequence of files will not render - cannot write to .mov file

    bvz2000

      So this is the weirdest issue and I am at my wits end.  I will try to explain as clearly as possible what is happening and what I have tried to do so far.

       

      I have 10 sequences of EXR's.  I want to crop each of these images and then write them out to 10 separate quicktime movies. No effects are being added.

       

      All 10 sequences are imported and individual comps are created for each one. These sequences are then added to the render queue. I am using the default settings for the quicktime codec (details at the end of this post).

       

      I am using OSX 10.10.5 and After Effects CC6. I have 1.31 Terabytes of free space on my disk.  I have 16GB of RAM (13 dedicated to AE).

       

      What is happening:

       

      6 of the 10 sequences render fine.

      4 of the 10 sequences fail to render, giving me the following errors:

       

      error: Rendering error while writing to file "/Volumes/Seagate 5TB/shows/my_show/cl205_2K_full.mov". An output module failed. The file may be damaged or corrupted. (-1610153464)

       

      Once the error occurs, every subsequent render in the render queue fails (even if it is not one of the "bad" 4 sequences). Once I restart, I can continue rendering the remaining of the 6 "good" sequences. But once again, once it hits one of the "bad" 4 sequences and fails, then every render after that will fail regardless of whether it is one of the "good" ones or not.

       

      No amount of restarting will allow me to render these 4 sequences.

       

      Sometimes they get part way through the sequence before failing.  Other times they simply fail right away.

       

      Each sequence fails on the same exact frame each time (unique to that sequence).  I.e. "bad" sequence #1 will always fail on frame 3.  #2 on frame 210.  And so on.  They always fail on the same frame each time I try to run them.

       

      The largest file size I have seen on a failed render is 710 MB.

       

      All of the sequences WILL play as part of a RAM preview without incident.

       

       

      Things I have tried that have all failed:

       

      The "bad" 4 sequences WILL write out as floating point tiff files. So I wrote them out as sequences of floating point tiffs (no alphas), re-imported them, created a new comp for each (no need for cropping this time because I cropped them as I was writing out the tiff sequence), and tried to render them.  Once again, they fail. I figured that this should "fix" any corrupt frames, but apparently not.

       

      I have opened the bad frames (plus two frames on either side) in Photoshop (the 32-bit tiff's I wrote out earlier), did a tiny clone stamp in an unobtrusive place, saved them back over themselves as 32 bit tiffs, and tried that. But it still fails on those "bad" frames.

       

      I have opened the bad frames (plus two frames on either side) in Photoshop (the 32-bit tiff's I wrote out earlier), did a select all, copy, paste into a new document, flatten, and save as over the original tiff file.  It still fails on the "bad" frames.

       

      I have disabled multiprocessing

       

      I have purged my cache memory and image cache memory

       

      I have emptied my disk cache

       

      I have embedded each of the comps as precomps into another set of comps (this worked earlier when I was scaling the renders down)

       

      I have tried rendering to different disks

       

      I have rebuilt the AE project from scratch

       

      I have disabled the 2 custom scripts that I had installed

       

      I have done a RAM preview before trying to render (RAM preview works perfectly)

       

      I have downgraded my project to 16 bits per channel from floating point

       

      Since I can render to a sequence of individual frames, I rendered out to .jpg files (highest quality), re-imported those, created a new comp for them, and tried to render them.  It still fails on the exact same frames.

       

      I copied the very first jpg (frame 0 that seems to render ok) over the "bad" frames as well as the two frames on either side of the bad frames.  It still fails on the same frame.

       

       

      What has worked:

       

      So far the only way I have been able to get it to work is to turn off multiprocessing and use h264 as my codec.  The problem with that is that, for reasons I cannot understand, if I use this codec it resizes my comps (down) from 2048x1152 to 2000x1152. That is not acceptable.

       

       

      My conclusions so far:

       

      It appears to fail on writing to the quicktime.  I thought it might have been multiprocessing that caused that error, but disabling that alone does not fix the issue. So somehow writing these particular frame numbers (it does not appear to have anything to do with the actual contents of the frame) always fails.  Why this frame number is different for each particular sequence of files, but always the same within these sequences is beyond me. It is maddeningly consistent and yet completely opaque as to what the issue is.

       

       

      What I need help with:

       

      I am not an After Effects guy and I know very little about quicktime or codecs (My usual software is Nuke and I almost exclusively write out to EXR sequences).  Could someone smarter and more experienced than I am chime in and maybe suggest a codec other than the default animation codec that will allow me to:

       

      A) complete the render

       

      and

       

      B) maintain my resolution

       

      Or if anyone has ANY insight as to what may be happening or other diagnostic steps I can take, I would very greatly appreciate it!

       

       

      Thanks!

       

       

      Sample log file:

       

      Adobe After Effects v11.0.4 (Macintosh 64) render log for project “ca2_v003.aep”

       

       

      Rendering started on 3/25/17 at 8:51:17 PM PDT

       

       

       

       

        3/25/17 8:51:17 PM PDT: Starting composition “cl205_2K_full_5”.

       

       

       

       

        Render Settings: Best Settings

        Quality: Best

        Resolution: Full

        Size: 2048 x 1152

        Proxy Use: Use No Proxies

        Effects: Current Settings

        Disk Cache: Read Only

        Color Depth: Current Settings

        Frame Blending: On for Checked Layers

        Field Render: Off

        Pulldown: Off

        Motion Blur: On for Checked Layers

        

        Solos: Current Settings

        Time Span: Work Area

        Start: 00000

        End: 00110

        Duration: 00111

        Frame Rate: 24.00 (comp)

        Guide Layers: All Off

        Skip Existing Files: Off

       

        Output Module: Lossless

        Output To: /Volumes/Seagate 5TB/shows/my_show/cl205_2K_full_5.mov

        Format: QuickTime

        Output Info: Animation

        Output Info: Spatial Quality = 100

        Include: Project Link

        Output Audio: Off

        Channels: RGB

        Depth: Millions of Colors

        Color: Premultiplied

        Resize: -

        Crop: -

        Final Size: 2048 x 1152

        Profile:  -

        Embed Profile: 

        

        Post-Render Action: None

        

        

        

       

        00000 (1): 0 Seconds

        00001 (2): 0 Seconds

      After Effects error: Rendering error while writing to file “/Volumes/Seagate 5TB/shows/my_show/cl205_2K_full_5.mov”. An output module failed. The file may be damaged or corrupted. (-1610153464)

        3/25/17 8:51:19 PM PDT: Finished composition “cl205_2K_full_5”.

       

       

       

       

       

       

        Total Time Elapsed: 1 Seconds

       

       

      Log closed on 3/25/17 at 8:51:19 PM PDT