5 Replies Latest reply on Dec 13, 2008 7:24 AM by *gsb*

    Disabling User Interaction

    skider Level 1
      I'm trying to make what basically amounts to an animation using Flex. One of the pieces in the animation is a text box that scrolls downwards. The problem is that the user can interact with it (hilight the text, scroll the scrollbar, etc.). I know that I can turn off text highlighting, and I can disable the scrollbar, but is there an easier way to disable interaction altogether on the app?

      The one thing that I've tried so far is to place a canvas across the top of the application, and have it as the top layer, but the user still seems to be allowed to scroll and highlight text through it. Any suggestions?
        • 1. Re: Disabling User Interaction
          Level 7

          "skider" <webforumsuser@macromedia.com> wrote in message
          news:ghul11$mv9$1@forums.macromedia.com...
          > I'm trying to make what basically amounts to an animation using Flex. One
          > of
          > the pieces in the animation is a text box that scrolls downwards. The
          > problem
          > is that the user can interact with it (hilight the text, scroll the
          > scrollbar,
          > etc.). I know that I can turn off text highlighting, and I can disable the
          > scrollbar, but is there an easier way to disable interaction altogether on
          > the
          > app?
          >
          > The one thing that I've tried so far is to place a canvas across the top
          > of
          > the application, and have it as the top layer, but the user still seems to
          > be
          > allowed to scroll and highlight text through it. Any suggestions?

          mouseEnabled=false or mousChildren=false may work for you...


          • 2. Re: Disabling User Interaction
            Gregory Lafrance Level 6
            mouseChildren="false" seems to do the trick.
            • 3. Disabling User Interaction
              Ansury Level 3
              You could disable the whole app, enabled="false" at the top level. But this 'blurs/dims' the entire ******* thing. I think you can use styles to change that.

              The possible issue with mouseChildren is that keyboard interaction still works if the text area can get focus. If all you have is that text area, you could get around that by setting tabEnabled="false" / editable="false" / selectable="false". So there's probably at least two ways unless 'enabled' has another effect that I forgot.
              • 4. Re: Disabling User Interaction
                Ansury Level 3
                Ah, it's enabled="false" and disabledOverlayAlpha="0" at the top level, give that a try.
                • 5. Disabling User Interaction
                  *gsb* Level 1
                  you could make a popup window, modal and set it's visibility to false.
                  No events will get through to the app.
                  Set the "global" in css as:

                  global {
                  modalTransparencyBlur: 0;
                  modalTransparency: 0;
                  modalTransparencyColor: white;
                  modalTransparencyDuration: 0;
                  }