4 Replies Latest reply on Apr 11, 2017 9:27 AM by brainiac37

    LR 6.9 hangs during iPhone import

    brainiac37

      I use LR 6.9 (perpetual license, signed in) on macOS 10.12.3.

      LR 6.9 [1106920] on a MacPro. Tried it with GPU enabled and disabled. No difference.

       

      Previously, I would use Apple Photos app to import photos & videos from my iPhone 7 Plus, export them as originals to disk, and then import them into LR. That workflow always worked just fine.

       

      Recently, I was experimenting with direct import of iPhone into LR:

           1. Go to the Import dialog

           2. Plug in iPhone 7 Plus. It shows up as a source

           3. Wait for all photos & videos to "load up" before clicking on the "Import" button

       

      After a few hours, I noticed that some 2000 photos & videos have been imported but then the asset count just stayed unchanged for another 40+ minutes. (I'm talking about the number to the right of the "Previous Import" catalog item.) The import dialog only showed halfway done.

       

      I tried quitting Lightroom but it just hung (had to force-quit). Even after restarting my Mac, I keep getting the same hang when trying to import directly from my iPhone. It's 100% reproducible. Any ideas?

        • 1. Re: LR 6.9 hangs during iPhone import
          Mohit Goyal Adobe Employee (Admin)

          Hi brainiac,

           

          Please refer the below article for optimizing Lightroom performance.

          Optimize Lightroom performance

           

          Thanks,

          Mohit

          1 person found this helpful
          • 2. Re: LR 6.9 hangs during iPhone import
            brainiac37 Level 1

            Hi Mohit,

             

            Thanks for the suggestion. In terms of optimizing LR:

             

            - I'm on the latest LR 6.9 I believe

            - I have a Mac Pro with 64GB RAM and 1TB of Flash SSD (400GB free). The LR catalog that I'm using is brand new (only has the 2000+ photos that I've imported from my iPhone)

            - I've tried with either GPU enabled or disabled

            - I have turned off Preview rendering during the Import

            - Autowrite XMP is already turned off

            - Camera RAW size was 1GB (now set to 4GB). But these are not RAW files, just JPG

             

            This hang is not any one file, as far as I can tell, because last night, I tried importing again, and after I clicked "Import", nothing happened for ~10 minutes. Then, all of a sudden, photos started being imported (shown in "Previous Import"). I was able to import another 661 photos/videos. After which, I let LR sit overnight (mac was not allowed to go to sleep), and it made no additional progress for 6+ hours.

             

            One common symptom is always that when I try to quit LR, I get the dialog that Import is in process; do I really want to quit. When I say "Yes", LR hangs. I get the spinning rainbow cursor and MacOS tells me that LR is unresponsive.

             

            I have captured sysdiagnose and samples of all Adobe processes. Can somebody help to figure this out? It is 100% reproducible.

             

            Thanks.

            • 3. Re: LR 6.9 hangs during iPhone import
              brainiac37 Level 1

              Any other ideas?

              • 4. Re: LR 6.9 hangs during iPhone import
                brainiac37 Level 1

                How do I mark this thread as NOT answered? I accidentally clicked on "Mark as assumed answered" and now the thread shows as answered. There's no way to undo.

                 

                It's my first time on the forum and had no idea what "Mark as assumed answered" mean. (Grammatically confusing to say the least.)