6 Replies Latest reply on Mar 29, 2017 2:03 PM by Arcnor

    Cannot read "rawData" of an XMP object

    Arcnor

      I have the following (supposedly simple) JSX code that I run after creating a new blank Photoshop document:

       

      var meta = app.activeDocument.activeLayer.xmpMetadata
      $.writeln(meta.rawData)
      

       

      However, for some reason, the only thing I can get out of this is an error on the second line saying "'value' property is missing". Even trying to view the object contents with the ESTK Data Browser makes it break (it cannot display more than the "parent" field, after that it shows the same error in the Data Browser itself).

       

      However, if I try to set the `meta.rawData` field to some random string before trying to read it in any way, it works (well, I get back my own string). Obviously, this is not a valid solution, as I want to read the field before setting it to anything else.

       

      Does anyone know if this is a bug (it certainly looks like it!) and how to workaround it?

       

      Thanks in advance