1 Reply Latest reply on Mar 31, 2017 2:03 PM by oksamurai

    Which version of Photoshop/Illustrator do I need to work with Character Animator?

    lola-landa

      I have worked with Illustrator/Photoshop CS6 for years now, I'm only in Creative Cloud for a single subscription for After Effects. Do I need to subscribe for Illustrator/Photoshop CC to create/edit puppets? Or there's a way to create puppets in older versions?

       

      How do I mark body parts in older versions?

        • 1. Re: Which version of Photoshop/Illustrator do I need to work with Character Animator?
          oksamurai Employee Moderator

          You might be able to make PSDs w/ CS6 and they would work - not 100% sure though if that's supported - but ultimately I think having the latest Photoshop is critical if you want to do any puppet creation or editing, particularly if you want to learn or start from any of the example characters (who were all made in newer versions). I'd suggest starting with what you've got, and if you run into a roadblock during the learning process, subscribe to the new PS for a month as you're getting your feet wet as a trial and seeing how that goes.

          1 person found this helpful