3 Replies Latest reply on Apr 1, 2017 9:42 AM by LeonD60

    Filter Not Finding Photos

    LeonD60

      I'm having a problem with the filter in Lightroom 6.9 on an iMac (Sierra 10.12.4).

       

      I have almost 19,000 photos in a folder (with subfolders under it) in my catalog. When I filter for 5 star photos, I get 14.

       

      I also have a Smart Collection of just 5 star photos. There are 77 photos in that collection. And all 77 photos are part of the larger, 19,000 photo folder.

       

      I would think the two should be equal but they are not.

       

       

      If I go into the 5 star Smart Collection, select a photo that is not part of the displayed 14 and do a "Go to Folder in Library", the system will bring me to that folder. Now if I go back to the main 19,000 photo folder and filter for the 5 star photos, the count will now be 15 and this photo will be included.

       

      I'm really not sure what's going on here. Any ideas?

       

      Thanks.

        • 1. Re: Filter Not Finding Photos
          Just Shoot Me Adobe Community Professional

          Is All Photographs selected in the Catalog area in the left panel? The filter bar only works on the folder, in the Folders area, or whatever is selected in the Catalog Area, like Previous Imported, All Synced files and so on. Or even for what is selected in the collections area.

          1 person found this helpful
          • 2. Re: Filter Not Finding Photos
            johnrellis Most Valuable Participant

            To build on Just Shoot Me's reply: Some of the 5-star photos may be hidden in collapsed stacks.  To test:

             

            1. Make sure you've selected All Photographs in the Catalog panel.

             

            2. Do Photo > Stacking > Expand All Stacks.

             

            Smart collections show the entire catalog.  Whereas filters only show matching photos in the currently selected source that are in expanded stacks or at the top of collapsed stacks.

            • 3. Re: Filter Not Finding Photos
              LeonD60 Level 1

              Thanks guys.  That is the correct answer.

               

              At one point, I did select All Photographs but that didn't help.  It wasn't until I expanded all my stacks.  Then the filter behaved as expected.

               

              Thanks again.