1 Reply Latest reply on Apr 1, 2017 5:48 PM by wobertc

    Upgraded to LRCC and now can't print

    pic-ee Level 1

      I upgraded from LR4 to CC a few months ago. I'v had no issues using CC (emailing developed photos, sending vacation photos to have a book made). Today for the first time with CC I have tried to print a photo to my Epson 3880, but it doesn't seem to communicate. Since I still have LR4 on my computer I tried that and was able to send a photo from an LR4 catalog to the printer without any issues. Unfortunately when I have tried to open the LRCC catalog hoping to print the photos with LR4, I receive a message that it can't open this new catalog. I'm running on Windows7.

       

      Any help in figuring out how to connect LRCC to the printer would be greatly appreciated.

       

      Thanks,

      Bob

        • 1. Re: Upgraded to LRCC and now can't print
          wobertc Adobe Community Professional

          FYI- Lr6 catalogs are not backward compatible with earlier Lr versions- as you have found. (Lr4 will not open the Lr6 catalog)

           

          When in the Print module, can you select your 3880 printer in the [Page Setup] dialog?

          Can you choose options for paper and printer properties?

          Have you tried re-installing the Printer Driver software?

           

          from another 'Bob'.