10 Replies Latest reply on May 26, 2017 1:44 AM by miked81851938

    "Pan behind Tool" and text editing are extreme slow and sluggish.

    miked81851938 Level 1

      Folks,

      I am experiencing an inconvenience that has grown too large to be ignored any further.

       

      Since at least After Effects CC 2015 (13.6.0) I get sluggish and choppy feedback when using the Pan Behind Tool to adjust Anchor Points on any sort of layer (solid, footage, text, etc...) as well as when using the Type tool to edit text. Also, dragging a marker across the timeline gives me the same sort of choppiness in feedback. This leads to unwanted selections and results. It´s happening regardless of the complexity of the project, although larger projects tend to increase the slowness of feedback. (See my machines specs below)

       

      I make this one thread, because I think those issues might be connected to each other, although I obviously have no clue about such things. Please let me know if I should make 3 different threads about that.

       

      #Pan Behind Tool

      When using the pan behind tool to manipulate anchor points, the little anchor point updates its position once or twice a second. That behavior leads to unwanted anchor point positions when I let go of the mouse button, otherwise I wouldn`t care about that too much.

       

      #Type Tool

      When editing Text - for example selecting specific chunks of text within a text layer - the same sluggish behavior leads to unwanted selections. I have no problem with text tools in other Adobe programs like Photoshop or Illustrator. This is using just the standard Windows fonts.

       

      #Marker

      When I drag a marker out of the little Comp marker bin that sits on the top right corner of the timeline - or when I try moving them at all, I get the same choppy behavior as explained above. Problem being that I frequently drop the marker on the wrong spot.

       

       

      I have noticed that as soon as I use any one of these tools, one logical CPU core is totally maxed out and the others jump to about 10% (looking at the windows task manager).

       

       

      I trashed my preferences.

      I had the same issue on win 8.1 (running win 10 now)

      I had the same issue using one instead of two graphic cards.

      I have the same issue after a clean installation of After Effects.

      I have the same issue after an installation of Windows 10 (upgrading from win 8.1).

      I am updating NVIDIA drivers as they appear on my screen (pretty often, 2-3 times a month).

      I used 3 different display setups (one 1920x1200, two 1920x1200 and two 3840x2160).

      I have used all versions of After Effects since 13.6.0, all showed the same issue.

      I think it was better before the Ae under-the-hood-architecture got overhauled.

      I have seen this behavior on one other machine, similar to mine.

      I am pretty happy with the overall performance of my machine and the After effects performance in general.

       

      I assume that something is interfering with the rendering/updating/redrawing of the UI, but that`s just guessing.

       

      I have also filed a bugreport, but I am not sure how much of a priority this thing is to Ae/Adobe, since I couldn`t find many reports like these online. Maybe I haven`t searched clever enough and someone can share this knowledge to me. I did find older and similar posts regarding UX/UI sluggishness, but none of them were about those tools, nor did they really help me fixing the problem.

       

       

      Thanks for reading this far and hopefully putting me in the right direction.

       

      cheers

      michi

       

       

      Software:

      AE 14.1

      Win 10 Home, 64bit, Version 1607

      NVIDIA Driver 378.92

      CUDA 8.0.0

       

      Hardware:

      Gigabyte X-99 Ud-4

      Intel i7-5960x 3 GHz, running at 4 GHz

      64GB RAM

      1 NVIDIA 980, 4GB RAM (outputting to 2x UHD Displays via displayport)

      1 NVIDIA 980ti, 6GB RAM

      1 SSD Samsung 850 PRO 1TB (System)

      1 SSD Samsung 850 PRO 1TB (Cache)

      1 SSD Samsung 850 EVO 2TB (Data)