2 Replies Latest reply on Dec 17, 2008 2:14 AM by tom2604

    Problems wit IE, RPC and SSL

    tom2604
      Hello,

      we want to switch our flex application completely to SSL. Initial attempts were successful - with Firefox.
      However we expected some problems with IE (v6 and v7). We received the following message in Internet Explorer after attempting a remote object call on a secure channel:
      quote:

      Channel.Connect.Failed error NetConnection.Call.Failed: HTTP: Failed: url: 'https: / / www.myapp.de/flex2gateway/cfamfsecure/'

      Here is our service-config.xml (which is also involved in compiling)
      quote:


      <?xml version="1.0" encoding="UTF-8"?>
      <services-config>

      <services>
      <service id="coldfusion-flashremoting-service"
      class="flex.messaging.services.RemotingService"
      messageTypes="flex.messaging.messages.RemotingMessage">
      <adapters>
      <adapter-definition id="cf-object" class="coldfusion.flash.messaging.ColdFusionAdapter" default="true"/>
      </adapters>

      <default-channels>
      <channel ref="my-cfamf-secure"/>
      </default-channels>

      <destination id="ColdFusion">
      <channels>
      <channel ref="my-cfamf-secure"/>
      </channels>

      <properties>
      <source>*</source>
      <!-- define the resolution rules and access level of the cfc being invoked -->
      <access>
      <!-- Use the ColdFusion mappings to find CFCs, by default only CFC files under your webroot can be found. -->
      <use-mappings>true</use-mappings>
      <!-- allow "public and remote" or just "remote" methods to be invoked -->
      <method-access-level>public and remote</method-access-level>
      </access>

      <property-case>
      <!-- cfc property names -->
      <force-cfc-lowercase>false</force-cfc-lowercase>
      <!-- Query column names -->
      <force-query-lowercase>false</force-query-lowercase>
      <!-- struct keys -->
      <force-struct-lowercase>false</force-struct-lowercase>
      </property-case>
      </properties>
      </destination>

      </service>
      </services>

      <channels>
      <channel-definition id="my-cfamf" class="mx.messaging.channels.AMFChannel">
      <endpoint uri=" http://{server.name}:{server.port}{context.root}/flex2gateway/" class="flex.messaging.endpoints.AMFEndpoint"/>
      <properties>
      <add-no-cache-headers>true</add-no-cache-headers>
      <polling-enabled>false</polling-enabled>
      <serialization>
      <instantiate-types>false</instantiate-types>
      </serialization>
      </properties>
      </channel-definition>

      <!-- use this for https, you probably want to create another destination -->
      <channel-definition id="my-cfamf-secure" class="mx.messaging.channels.SecureAMFChannel">
      <endpoint uri="https://{server.name}:{server.port}{context.root}/flex2gateway/cfamfsecure/" class="flex.messaging.endpoints.SecureAMFEndpoint"/>
      <properties>
      <add-no-cache-headers>true</add-no-cache-headers>
      <polling-enabled>false</polling-enabled>
      <serialization>
      <instantiate-types>false</instantiate-types>
      </serialization>
      </properties>
      </channel-definition>
      </channels>


      <system>
      ...
      </system>

      </services-config>



      As already written, it works fine with Firefox.
      Has anybody an idea?


      regards
      Thomas