5 Replies Latest reply on Apr 8, 2017 3:41 AM by BKBK

    CFExecute java.io.FilePermission Access Denied

    Steven6282 Level 1

      Hello,

      I come here once again seeking help on a problem that I can't find any information about.  I don't have much hope as the last few times I've posted here I have not even gotten a response, but I don't know where else to turn when nothing on web searching is relevant.

       

      I'm trying to get my company upgraded to CF2016 from CF9.  I've gotten around a lot of problems so far, but I've ran into another one.  One part of our software needs to use <cfexecute to run some commands on the server.  Specifically, SVN commands for our deploy to production process.  In CF9 we were able to run <cfexecute without any issues.

       

      In CF2016, when I try to execute a file I'm getting:

      An exception occurred when invoking an external process.

      The cause of this exception was that: java.security.AccessControlException: access denied ("java.io.FilePermission" "/coldfusion_apps/deployer/test.sh" "execute").

       

      As you can see here, I've created a simple test.sh file for testing purposes.  I've tried dozens of variations of adding java.io.FilePermission "/coldfusion_apps/deployer/*", "read,execute"; to the coldfusion.policy file, as well as the neo_jaas.policy file, and for good measure the default java.policy file and default javaws.policy.  I've also tried adding variations of java.security.AllPermission and other things I've found on the web.  Tried disabling the security manager completely by omitting -Djava.security.manager in the jvm.config file as suggested by some websites, but nope.

       

      The user that coldfusion is run as has full read, write, exeucte access to the directory and file that I'm attempting to cfexecute.  I've even tried setting the file and directory structure to permission 777 (world readable, writable, executable), and still no go.

       

      I cannot figure out what the heck I need to do to make this thing allow executing files...

       

      If anyone can help, it would be greatly appreciated.  Nearing the deadline to have this conversion completed, and if I can't get this working through CF soon, I'm going to have to rewrite our deployer in PHP or something.

       

      Thanks