3 Replies Latest reply on Apr 17, 2017 7:20 AM by theWoosh

    Problems upgrading standalone Lightroom 6.0

    theWoosh

      Hi

      I bought a new sony A7ii and want support for the 14 bit raw files on my Mac (running OS X 10.10.5 Yosemite). I purchased and installed Lightroom 6.0 standalone, but this didn't allow raw file import so tried to upgrade it.

      Got the error message 'Installation failed. Error Code: U44M2P7' several times. Tried uninstalling the original and then reinstalling it and tried again. same problem.

      I then found the manual upgrades on the Adobe site and tried upgrading one by one (6.01, 6.1,6.2 etc) but they all failed with the same error...

       

      Looking at the log files, I can see the following:

      04/06/17 17:03:28:464 | [ERROR] | | ASU | UWANative | UWANative | | | 4211370 | install updates returned error Code :U44M2P7

      04/06/17 17:03:28:464 | [ERROR] | | ASU | UWANative | UWANative | | | 4211370 | install updates returned statusCode:44, errorCode:7

      04/06/17 17:03:28:951 | [INFO] | | ASU | PDApp | UWA.UpdatesProxy | | | 4211370 | getting currently processing update name of update num: 0

      04/06/17 17:03:28:951 | [ERROR] | | ASU | PDApp | Updater.InstallUpdatesCommand | | | 4211370 | InstallUpdates : encountered some error...

      04/06/17 17:03:28:952 | [INFO] | | ASU | PDApp | Updater.InstallUpdatesCommand | | | 4211370 | -----INSTALLATION FINISHED------

      04/06/17 17:03:28:954 | [FATAL] | | ASU | UWANative | UWANative | | | 4211370 | Error '38' occured in Updater core in CheckForUpdates

      04/06/17 17:03:28:954 | [ERROR] | | ASU | UWANative | UWANative | | | 4211370 | CheckForUpdates: Unique error code vaule is :U41M2U38

      04/06/17 17:03:29:498 | [INFO] | | ASU | PDApp | Updater.PopulateFinishScreenCommand | | | 4211370 | -----STARTED POPULATING FINISH SCREEN------

      04/06/17 17:03:29:502 | [INFO] | | ASU | PDApp | UWA.FINISH | | | 4211370 | getErrorSuccessStatus : Error found in install Lightroom CC (2015.9) / 6.9

      04/06/17 17:03:29:503 | [INFO] | | ASU | PDApp | UWA.UpdatesProxy | | | 4211370 | complt apps length is : 0

      04/06/17 17:03:29:504 | [INFO] | | ASU | PDApp | UWA.UpdatesProxy | | | 4211370 | failed apps length is : 1

      04/06/17 17:03:29:504 | [INFO] | | ASU | PDApp | UWA.UpdatesProxy | | | 4211370 | complted apps length is : 0

      04/06/17 17:03:29:504 | [INFO] | | ASU | PDApp | UWA.UpdatesProxy | | | 4211370 | incomplted apps length is : 0

      04/06/17 17:03:29:505 | [INFO] | | ASU | PDApp | Updater.PopulateFinishScreenCommand | | | 4211370 | None of the updates could be applied

       

      Does anyone have any suggestions? tearing my hair out here!...

        • 1. Re: Problems upgrading standalone Lightroom 6.0
          F. McLion Adobe Community Professional & MVP

          Please remove all previous Lightroom 6 installations and reboot.

          Then download the 6.0 installer directly from the link below and then install it - reboot.

          Now download and then install the 6.9 update.

          Download Photoshop Lightroom

           

          You always need the base installer first na then the latest (cumulative) update.

          1 person found this helpful
          • 2. Re: Problems upgrading standalone Lightroom 6.0
            theWoosh Level 1

            thanks for your reply - I will try this (though it is not much different from what I already tried)...

            For information can you tell me if Lightroom uses the Adobe Camera Raw app or does it handle raw files natively?

            • 3. Re: Problems upgrading standalone Lightroom 6.0
              theWoosh Level 1

              ...I followed your instructions and as I expected, the same problem occurred when attempting the upgrade -

              Update failed:

              Lightroom CC (2015.9) / 6.9

              Installation failed. Error Code: U44M2P7

               

              However I then tried again using the Lightroom update installer and got a different error code - on inspecting the installer log I saw the following:

              'the path "/Applications/Adobe" already exists and is not a directory, cannot create path "/Applications/Adobe/AdobePatchFiles",Please rename/delete "/Applications/Adobe" and retry'

              ...there was a text file called Adobe in the Applications folder that had been sitting there since 2005 (seems it had been put there by an adobe trial back then). Once ths was deleted I was able to complete the upgrade :-)