6 Replies Latest reply on Dec 17, 2008 8:46 PM by Raju Rao

    unable to generate AIR

    Raju Rao Level 1
      Hi,

      I have built a Flex app using as components. When I use the debugger ADL I can use the application however when I run the ADT command I receive a

      "Root content test.swf is missing from package".

      This even though the test.swf is in the current directory.

      When I tried using the same with a simple HelloWorld program in Flex is works.

      I guess it is something got to do with the components. Any suggestions?

      Thanks,

      Raju Rao
        • 1. Re: unable to generate AIR
          tzeng Adobe Employee
          How you run your Flex app.? In Flex Builder? Then you better use Flex Builder to package the AIR file.

          It is not because the components. The test.swf file is not in the right place.

          -ted
          • 2. unable to generate AIR
            Joe ... Ward Level 4
            ADT is, in many respects, like a ZIP or archive utility. You must specify which files to include in the package. The only file added automatically is the application descriptor. (Flex Builder does add the application files for you, though.)

            See http://help.adobe.com/en_US/AIR/1.5/devappsflex/WS5b3ccc516d4fbf351e63e3d118666ade46-7fd6. html for information about using ADT.

            If you still have trouble, maybe you could post the content element of your app descriptor, the ADT command line you are using, and your application directory structure.
            • 3. unable to generate AIR
              Raju Rao Level 1
              Thanks, Ted/Joe.

              I too gathered that it is expecting the swf file somewhere else ... but could not "see" the problem. Here are details of the application.

              Directory Structure:

              test[dir]
              ...test.xml
              ...test.mxml.
              ...test.as
              ...com[dir]
              .........flashback[dir]
              ..............kelements[dir]
              ...................MySprite.as
              .........................
              ................... (all my components)

              TEST.XML contents
              <?xml version="1.0" encoding="UTF-8"?>
              <application xmlns=" http://ns.adobe.com/air/application/1.5">
              <id>flashBack.flex.desktop</id>
              <version>0.1</version>
              <filename>FlashBackv0.1</filename>
              <initialWindow>
              <content>test.swf</content>
              <visible>false</visible>
              <systemChrome>none</systemChrome>
              <transparent>false</transparent>
              </initialWindow>
              </application>

              COMMAND FROM APPLICATION DIRECTORY TO CREATE SWF
              C:/Progra~1/Adobe/AdobeFlexSDK/bin/amxmlc test.mxml

              (Note: this swf works with ADL test.xml)

              COMMAND FROM APPLICATION DIRECTORY TO GENERATE AIR
              C:/Progra~1/Adobe/AdobeAIRSDK/bin/adt -package -storetype pkcs12 -keystore sampleCert.pfx test.air test.xml test.swf

              Thanks for the help,

              Raju
              • 4. Re: unable to generate AIR
                Joe ... Ward Level 4
                I note that you are running amxmlc and ADT from different SDK directories. I suspect that the ADT program you are running is from an older version of the SDK and doesn't recognize the version 10 SWF file produced by the newer Flex SDK as a valid SWF file. Try running ADT from your AdobeFlexSDK folder instead of your AdobeAIRSDK folder.
                • 5. Re: unable to generate AIR
                  Raju Rao Level 1
                  Hi Joe,

                  Thanks for the response. I tried the following:

                  1. Called ADT from the flex SDK directory. It gives the same error.

                  2. Downloaded the latest SDK. Called ADT from the new directory. It gives the same error.

                  What intrigues me is that ADL works. So the question is why does ADT throw up this error? Can someone help in identifying how ADL is different from ADT?

                  Also, let me mention again that with a simple HelloWorld application I am able to generate the air file. But when I use components it fails. Again I have developed a few HTML-Ajax applications including bridging etc and they work. But with Flex and components this is my first one.

                  Any help will be appreciated?

                  Thanks,

                  Raju
                  • 6. Re: unable to generate AIR
                    Raju Rao Level 1
                    Gosh! got it working :-)

                    Realised that the filename tag in the xml file was "flashbackv0.1". Just changed that to "test" and it worked.

                    The clue was that I tried to generate an air file from one of the samples downloaded and it worked. On closely noting the difference I identified the above one.

                    Still this intrigues me. I thought the filename could be anything!

                    Thanks for the help,

                    Raju