1 Reply Latest reply on Apr 11, 2017 7:17 AM by Liz, Typekit Support

    Typekit has no "Sync" button

    ConnorBlank Level 1

      Hello,

      I am currently trying to make a header in a cool font I found on type kit. I am making this, as you can see from the screenshots, for a school. Anyways, I synced fonts, or at least hit the sync button, on the fonts I wanted in the Typekit website. When I went to the panel for fonts in my creative cloud launcher, the thing would not have a button to let me sync. However, whenever I synced a new font I had never tried syncing before, it would show a panel for a second or two and then it would go away. Then, I would get a notification (from my computer, Windows 10) saying that the font was just uninstalled. To troubleshoot, I already tried:

      1. Turning on Sync (It was on)

      2. Cycling the sync (Turning it off then on)

      3. Quitting the Creative Cloud App and all its related processes

      4. Restarting the computer

      5. Checking for updates

      6. Trying a different app

      7. Trying a different font (With a different app as well)

      8. Looking through forums

       

      It is becoming frustrating why this one facet doesn't work. I need these fonts soon.

        • 1. Re: Typekit has no "Sync" button
          Liz, Typekit Support Adobe Employee

          > Then, I would get a notification (from my computer, Windows 10) saying that the font was just uninstalled.

           

          I'm sorry that you ran into trouble with this. It sounds like you are running into a bug in the Windows 10 operating system which blocks you from installing new fonts.

           

          If you check the sync log files ( https://helpx.adobe.com/typekit/kb/troubleshoot-font-syncing.html#logs ), you should see an error like:

           

          Error: [livetype] AddFontResourceEx failed, code=0

          Error: [livetype] Failed to activate font

           

          You can also feel free to email us your log files at support@typekit.com, and we can confirm this for you.

           

          This is a bug in Windows 10, which we've heard will be fixed in a future update to the operating system.

          In the meantime, turning on the firewall in Windows should allow the fonts to sync:

           

           

          1. From Windows menu on the lower left corner of the screen, go to Settings > Network & Internet > Ethernet > Windows Firewall > Turn Windows Firewall on or off.

           

           

          2. Turn ON Windows firewall for both public and private networks

           

           

          3. Then turn off font sync in the Creative Cloud application, wait a moment, and then turn it back on. The option to do this is under the gear icon in Preferences > Creative Cloud > Fonts ("Typekit on/off").

           

           

          If that doesn't solve it, the next steps to try are:

           

           

          A. check whether there are any malware blockers installed on this computer, such as Hitman Pro. Sometimes there is an option to "block untrusted fonts" which will need to be turned off to allow Typekit to sync.

           

           

          B. If your computer managed by your university, there is another setting in Windows where you can tell it to block untrusted fonts, which they might turn on by default. It requires some deep digging to check or change, though, and I would not ask you to do it yourself unless you're familiar with the process already.

           

           

          Here are the details:

          https://support.microsoft.com/en-us/help/3053676/windows-10-technical-preview-adds-a-featu re-that-blocks-untrusted-fonts

           

           

          If your computer is managed/set up by the IT department, it would be helpful to ask them whether they have enabled this option on the computer and (if they have) could it be changed?

           

           

          I hope that this helps,

          -- liz