5 Replies Latest reply on Apr 13, 2017 11:30 AM by mikih329

    Photoshop "Select and Mask" Tool throws Program Error message (Mac 10.12.4)

    mikih329

      Hi everyone!

      I've been looking all over the Internet about this issue, have tried almost everything, and still can't find a solution.

      I am currently working on an image that requires me to make a selection, and then use the Select and Mask tool to make a composite. After making my selection and opening Select and Mask, I tried to select the "Onion Skin" option to help select some hair on my subject.

      I am met with an error message that simply reads: "Could not apply the workspace because of a program error."

      I noticed that this is something that happened AFTER updating my MacBook to Sierra 10.12.4, and updating my Photoshop CC to the most current version.

      I also noticed that this error message shows up when I try to apply the "Onion Skin" to images that I open in Photoshop CC through Lightroom CC (via Photo/Edit In/Photoshop CC 2017), but not with images that have been opened and edited in the updated version of Camera RAW. I think it's worthy to note that my Lr CC has been updated as well.

      From previous threads, I was able to at least find my Library folder and locate the PSErrorLog.txt file and found this:

      2017:04:11 13:20:15 : /Volumes/workarea/PS_18.1_Mac_Daily_Retail/20170309.r.207/photoshop/main/photoshop/source s/SmartBrushTool.cpp : 3367 : REQUIRE failed

      2017:04:11 13:22:02 : /Volumes/workarea/PS_18.1_Mac_Daily_Retail/20170309.r.207/photoshop/main/photoshop/source s/SmartBrushTool.cpp : 3367 : REQUIRE failed

      2017:04:11 13:31:20 : /Volumes/workarea/PS_18.1_Mac_Daily_Retail/20170309.r.207/photoshop/main/photoshop/source s/SmartBrushTool.cpp : 3367 : REQUIRE failed

      2017:04:11 13:31:25 :            0xb50 of type P5_ADsc not found : 1 : REQUIRE failed

      2017:04:11 13:31:25 : /Volumes/workarea/PS_18.1_Mac_Daily_Retail/20170309.r.207/photoshop/main/photoshop/xcode/ ../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed

      2017:04:11 13:31:25 :            0xb58 of type P5_ADsc not found : 1 : REQUIRE failed

      2017:04:11 13:31:25 : /Volumes/workarea/PS_18.1_Mac_Daily_Retail/20170309.r.207/photoshop/main/photoshop/xcode/ ../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed

      2017:04:11 13:31:25 :            0x1d8 of type P5_ARef not found : 1 : REQUIRE failed

      2017:04:11 13:31:25 : /Volumes/workarea/PS_18.1_Mac_Daily_Retail/20170309.r.207/photoshop/main/photoshop/xcode/ ../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed

      2017:04:11 13:38:26 :            0xb30 of type P5_ADsc not found : 1 : REQUIRE failed

      2017:04:11 13:38:26 : /Volumes/workarea/PS_18.1_Mac_Daily_Retail/20170309.r.207/photoshop/main/photoshop/xcode/ ../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed

      2017:04:11 13:38:26 :            0x198 of type P5_ARef not found : 1 : REQUIRE failed

      2017:04:11 13:38:26 : /Volumes/workarea/PS_18.1_Mac_Daily_Retail/20170309.r.207/photoshop/main/photoshop/xcode/ ../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed

      2017:04:11 13:38:26 :            0xb28 of type P5_ADsc not found : 1 : REQUIRE failed

      2017:04:11 13:38:26 : /Volumes/workarea/PS_18.1_Mac_Daily_Retail/20170309.r.207/photoshop/main/photoshop/xcode/ ../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed

      2017:04:11 13:39:04 : /Volumes/workarea/PS_18.1_Mac_Daily_Retail/20170309.r.207/photoshop/main/photoshop/source s/SmartBrushTool.cpp : 3367 : REQUIRE failed

      2017:04:11 13:39:32 : /Volumes/workarea/PS_18.1_Mac_Daily_Retail/20170309.r.207/photoshop/main/photoshop/source s/SmartBrushTool.cpp : 3367 : REQUIRE failed

      2017:04:11 13:41:34 : /Volumes/workarea/PS_18.1_Mac_Daily_Retail/20170309.r.207/photoshop/main/photoshop/source s/SmartBrushTool.cpp : 3367 : REQUIRE failed

      2017:04:11 13:44:08 : /Volumes/workarea/PS_18.1_Mac_Daily_Retail/20170309.r.207/photoshop/main/photoshop/source s/SmartBrushTool.cpp : 3367 : REQUIRE failed

       

      Unfortunately, I'm not THAT savvy, so I'm not sure what these necessarily mean... Are there tools/applications within my Photoshop that are misbehaving and causing other tools to stop working, or is there something deeper going on?

      I also don't know if other tools have been affected by the same error, so far it's just the tools within "Select and Mask" tool that don't work. I understand that other people have had the same message pop up with other tools, and somehow have been able to fix their issues. All attempts to try what worked for them have done nothing for me.

      If someone could help me figure out what's going on with my Ps CC, I would really appreciate it!

      Thanks!

      -Miki