3 Replies Latest reply on Apr 18, 2017 1:49 PM by surajpindoria

    autoload is a pain in the a$$

    orgCrisium Level 1

      I just started using the phonegap and i'm very pleased with the results. only minor problems... but one of the minor problems is making development a pain.

      and that is the autoreload!

       

      It keeps spamming the console making difficult to sort through the messages to see what is going on.

       

      I am using the desktop phonegap and there is no option to turn it off. I read that I can turn it off if I start my application with the CLI and use --no-autoreload which works... but then the page does not update when pressing F5. So basically there is no good solution.

       

      i'm tired of see a million messages with: XHR finished loading: GET "http://192.168.1.39:3000/__api__/autoreload".

       

      please somebody fix this.

       

      Peter

        • 1. Re: autoload is a pain in the a$$
          kerrishotts Adobe Community Professional

          I'm assuming you're using Chrome to test with, in which case you can disable the XHR messages by going into your developer console, going into settings, and then underneath "Console" uncheck "Log XMLHttpRequests"; this will prevent the auto reload from displaying on your console. (Of course, it might prevent other useful XHR logging, but I don't know if you're using XHR in your app or not.)

           

          There are lots of other reloading tools out there that you could use if you don't want to use PG's server, but see if the above helps first.

          • 2. Re: autoload is a pain in the a$$
            orgCrisium Level 1

            thank you so much for pointing out that the XHR messages could be turned off in chrome.

            my points are still valid, but this is an acceptable solution.

             

            thank you very much,

            Peter

            • 3. Re: autoload is a pain in the a$$
              surajpindoria Adobe Employee

              Which version of the desktop app are you using?

               

              The default for the autoreload logs is that they should not be output unless you use the '--verbose' flag in the CLI. I just checked on the latest version of the desktop app, 0.4.3, and I am not seeing those logs either in the app or on the chrome developer console.