3 Replies Latest reply on Apr 18, 2017 1:46 AM by maximp61010792

    PGB сeased to show icons and splash screens in iOS

    maximp61010792

      Hello!

      Suddenly, without changing the configuration file, icons and splashcreens were no longer displayed.

       

      I have www folder, config.xml and all icons and splashscreens in one folder.

      Config.xml contains such definitions:

       

      <platform name="ios">

       

               <icon src="icon.png"/>

               <icon src="icon-180.png" width="180" height="180" />

               <icon src="icon-60.png" width="60" height="60" />

              <icon src="icon-120.png" width="120" height="120" />

              <icon src="icon-76.png" width="76" height="76" />

               <icon src="icon-152.png" width="152" height="152" />

              <icon src="icon-40.png" width="40" height="40" />

              <icon src="icon-80.png" width="80" height="80" />

              <icon src="icon-57.png" width="57" height="57" />

              <icon src="icon-114.png" width="114" height="114" />

              <icon src="icon-72.png" width="72" height="72" />

              <icon src="icon-144.png" width="144" height="144" />

              <icon src="icon-29.png" width="29" height="29" />

              <icon src="icon-58.png" width="58" height="58" />

              <icon src="icon-50.png" width="50" height="50" />

              <icon src="icon-100.png" width="100" height="100" />

             <icon src="icon-87.png" width="87" height="87" />

             <icon src="icon-167.png" width="167" height="167" />

       

              <splash src="splash.png" />

              <splash src="splash320x480.png" width="320" height="480"/>

              <splash src="splash640x960.png" width="640" height="960"/>

              <splash src="splash768x1024.png" width="768" height="1024"/>

              <splash src="splash1536x2048.png" width="1536" height="2048"/>

              <splash src="splash640x1136.png" width="640" height="1136"/>

              <splash src="splash750x1334.png" width="750" height="1334"/>

              <splash src="splash1242x2208.png" width="1242" height="2208"/>

              <splash src="splash2048x2732.png" width="2048" height="2732"/>

       

      </platform>

       

      With this rig i made dozens of ideal builds. Now, instead of all my pictures are showing default.

      I'm trying to move pictures into folders, rename pictures, add / remove tags and options in config.xml - nothing helps.

       

      How to make bug report?

       

      From log:

      /* com.apple.actool.document.warnings */

      /tmp/gimlet/2572955/project/Kluchi/Images.xcassets:./AppIcon.appiconset: warning: A 60x60@2x app icon is required for iPhone apps targeting iOS 7.0 and later

      /tmp/gimlet/2572955/project/Kluchi/Images.xcassets:./AppIcon.appiconset: warning: A 76x76 app icon is required for iPad apps targeting iOS 7, 8, and 9

      /tmp/gimlet/2572955/project/Kluchi/Images.xcassets:./AppIcon.appiconset: warning: A 76x76@2x app icon is required for iPad apps targeting iOS 7.0 and later

      /tmp/gimlet/2572955/project/Kluchi/Images.xcassets:./AppIcon.appiconset/[][ipad][76x76][][ ][2x]: warning: AppIcon.appiconset/icon-76@2x.png is 180x180 but should be 152x152.

      /tmp/gimlet/2572955/project/Kluchi/Images.xcassets:./AppIcon.appiconset/[][iphone][40x40][ ][][3x]: warning: AppIcon.appiconset/icon-60@2x.png is 180x180 but should be 120x120.

      /tmp/gimlet/2572955/project/Kluchi/Images.xcassets:./AppIcon.appiconset/[][ipad][76x76][][ ][1x]: warning: AppIcon.appiconset/icon-76.png is 180x180 but should be 76x76.

      /tmp/gimlet/2572955/project/Kluchi/Images.xcassets:./AppIcon.appiconset/[][iphone][60x60][ ][][2x]: warning: AppIcon.appiconset/icon-60@2x.png is 180x180 but should be 120x120.

       

      But my icons have right sizes. And again, I've already made a bunch of assemblies with such parameters.

      Everything has stopped working immediately with no changes on my part.