9 Replies Latest reply on Apr 17, 2017 5:25 PM by TheOriginal150mph

    AE 2017 playback slow

    TheOriginal150mph Level 1

      My file - my 2nd ever AE project - started playing back slow and now won't even play all the way through. IDK what I added that did this.

       

      Looking online I started reading several threads, eg After Effects 2017 Playback is Extremely Slow :

       

      ...I called support and they said the reason the frames are dropping when RAM preview attempts to cache is because the folder was altered in some way (could be any number of reasons why). Anyhow - they said if you go to adobe through appdata and look for the folder called 'roaming'>then open "commmon"  then find all your aftereffects folders and rename them to Aftereffects_old , open the program and it should work. at least it does for me.

       

      IDK what it means to "go to Adobe through appdata". But my computer doesn't have a  "roaming" folder or even a "common" folder that Search finds.

       

      Helpful advice appreciated

       

      AE  2017MacBookPro | OS 10.12.3  | 4GB ram

        • 1. Re: AE 2017 playback slow
          Roei Tzoref Adobe Community Professional

          appdata is for windows. on Mac it's a different process.

           

          what do you mean slow? what exactly is happening? what does your setup contain in terms of effects and resolution. some projects can take some time to preview, others can preview and play almost at real time. you are very low on RAM - 4GB is the minimum requirement and not the recommended (which is 8) so you should expect some processing slowness and definitely shorter amount of preview time because Ae is depended on how much it can save to RAM.

           

          more about RAM and preview here:

          https://helpx.adobe.com/after-effects/using/memory-storage1.html

          • 2. Re: AE 2017 playback slow
            TheOriginal150mph Level 1

            Thanks for the reply. I'll read up on the memory info but want to get this reply posted asap.

             

            I've been building my 60 sec / 1280x720 / 24fps comp. for several days adding numerous pre-comps and graphics and it played well until yesterday. One of the many newer things I added was a different aiff soundtrack file and I did a reverse time on one pre-comp, but removing those doesn't change anything. A previous version (before 6 hrs of new work) still plays fine.

             

            When rewound and played in AE from the beginning, the comp plays fine for a few seconds, then the speed slows - the visuals slow down & the audio pitch gets warped-sounding like its running out of juice. Playback doesn't get further than the green bar (attached screencap) then it stops and begins again. If I put the playhead at the 30 second mark it plays 20-30 seconds then loops back to the 30 sec. mark.

             

            I tried clearing the cache but that didn't help. I thought if i could get say 3 different sections each playing through, everything would be cached and it would play normal again but it only seems to cache the current section and discard earlier caches.

             

            I know this laptop isn't set up well for animating in AE very well - RAM or graphics card-wise and I'd expect some hiccups but I thought it could at least get me through this project. It won't even play all the way through now so it seems like something more dire than just not enough ram is going on. I have a much better AE workstation at work where i can check the file tomorrow so maybe its just my laptop isn't cutting it...

             

            I put the file and assets (74MB) on Google Drive should you be kind enough to take a look : AE project_170416.zip - Google Drive 

             

            Would very much appreciate insight...

             

            Screen Shot 2017-04-16 at 5.52.05 PM.png

            • 3. Re: AE 2017 playback slow
              TheOriginal150mph Level 1

              I think I've found the answer but too late to alter my post.

               

              I'm now at my work computer and it plays fine.

               

              I failed to look at the fact that my project was on a removable drive (so I could take it to work and use my much more powerful Mac workstation there) and even though my laptop seems to have plenty of cache space, it's not enough.

               

              I will have to be more mindful of cache as that (tentatively) seems to be my issue here.

               

              If you did download and look at my file - there is one problem I need to solve - The audio hiccups at the beginning although the aiff is fine.. thoughts?

              • 4. Re: AE 2017 playback slow
                Roei Tzoref Adobe Community Professional
                The audio hiccups at the beginning although the aiff is fine.. thoughts?

                try this: under preferences->display there is "hardware acceleration" check box. turn it off and see if that solves the hiccup.

                • 5. Re: AE 2017 playback slow
                  TheOriginal150mph Level 1

                  Ok thx tried that. No luck.

                   

                  Trying to dial in on whats happening:

                   

                  At approx. 2 seconds from where the playhead begins (not just the beginning of the comp), and for just a second, AE seems to be playing the aiff double/twice simultaneously - but maybe slightly off sync, causing an echo. IDK if I'm describing it correctly.

                   

                  I thought originally it was at the beginning of the comp but now see its 2 sec's from wherever I start playing it

                   

                  I deleted the audio layer and aiff file from Project and reimported, re-added. nope...

                   

                  Some loop I've got affecting it somehow?

                  • 6. Re: AE 2017 playback slow
                    Roei Tzoref Adobe Community Professional

                    I have examined the project, the audio preview is fine in my system.

                     

                    try this:

                    1. set you preview settings in the preferences to mute if audio is not real time

                    2. reset your preview settings for numpad 0 and mark the checkbox for cache before playback

                     

                    and of course don't forget to leave hardware acceleration OFF under preferences->display

                    • 7. Re: AE 2017 playback slow
                      TheOriginal150mph Level 1

                      Thanks Roei. Once again you've aced my problem and it seems to be playing through correctly now with these settings and not duping the audio in that one spot! (Here on my work computer at least, hopefully the same on my laptop at home later)

                       

                      The bad news is of course after I rewind and press Play, AE goes through caching the entire 60 second composition, which takes about 20 seconds, and is kinda disappointing I have to do that from now on just to overcome this bizarre audio glitch that isn't in the audio file. But maybe that delay is what you experts deal with regularly?

                       

                      Some add'l questions if you'd kindly indulge me:

                       

                      Has what you've done here showed that AE is not able to play through with default settings - likely due to the way I've got my file set up? I've used images that are up 2X bigger than needed, because I was planning on doing a bunch of zooming, but I didn't think any were over-the-top big.

                       

                      Are these settings you recommend as default? I'm wondering if they're more diagnostic-like.. eg,  I like the Spacebar for Play - does your Numpad 0 setting have any effect on the improvement? and I kinda like to play from CTI rather than Start of Range.

                       

                      Also, I'd made this cell phone vid earlier where the problem can be heard on the word "most". It's not terrible bad or anything, just annoying b/c it's not in the aiff.

                      audio problem.m4v - Google Drive

                       

                      thx again!

                      • 8. Re: AE 2017 playback slow
                        Roei Tzoref Adobe Community Professional
                        The bad news is of course after I rewind and press Play, AE goes through caching the entire 60 second composition, which takes about 20 seconds, and is kinda disappointing I have to do that from now on just to overcome this bizarre audio glitch that isn't in the audio file. But maybe that delay is what you experts deal with regularly?

                        Ae is designed to play cached frames in real time. meaning two things:

                        1. it is not designed to play in real time, it has to save the frames to RAM first

                        2. your cache is limited - you can only play a clip in real-time as long as your RAM will allow.

                         

                        about previewing:

                        • in your case, you have a composition with edited shots. Rick Gerard, one of our Ae gurus here, usually says: "Ae is designed for creating shots and not editing movies". shots are usually quite short and will preview fine. an animated movie such as yours would benefit if you created the shots in Ae, but compiled them in an NLE like premiere. you would have much more control of timing between the shots and this would help you with the storytelling. although I would add that usually I also like assemble many of my animations right in Ae, even if it's not the proper way of doing it.
                        • if you do have a shot with a longer duration, you don't usually preview the whole thing in one go but in parts.
                        • you usually don't preview at full quality 100%, but set it to half or quarter in the resolution pop up. some like me use shortcuts to set it to half or quarter. some like to change the resolution to auto so it will automatically reduce the quality based on the resolution.
                        • sometimes, after a quick check, you would actually render the whole composition in a compressed format such as H.264 in order to check that it is good all the way through and watch it through any player.
                        • sometime you would pre-render parts of your compositions if they are intensive in processing or even the whole master composition it as a full quality sequence, import it and watch it at full quality to see if there are any errors. if there is a glitch somewhere you can only fix those frames and don't have to render the whole thing all over again. (in long detailed compositions I would create a full quality proxy for my compositions)

                         

                        more about improving performance is in here: Improve performance in After Effects

                         

                        Has what you've done here showed that AE is not able to play through with default settings - likely due to the way I've got my file set up?

                        it's not your setup but partly your Computer and most of it is because of how AE is built. it is not able to play in real-time, and most of the compositions won't play back in real-time. when the caching is taking time, you are left with a choice  to either delay the video (fps) or the audio (sometimes a disturbing pitch) or patiently cache the frames first and only then play them back which I always prefer.

                         

                        Are these settings you recommend as default? I'm wondering if they're more diagnostic-like.. eg,  I like the Spacebar for Play - does your Numpad 0 setting have any effect on the improvement? and I kinda like to play from CTI rather than Start of Range.

                        these are my recommended settings:

                        I always like to play from current time. I set my numpad 0 to cache first (the old way RAM Preview used to work prior to CC2015) and I set my spacebar to show me also the overlays like the old spacebar prior to CC2015 used to do. sometime I disable audio for spacebar (also the pre CC2015 behavior)

                         

                        about your file - yes, it is annoying. btw not sure why you created m4v, I usually stick with the mp4 presets in AME and create a mp4 file.

                        1 person found this helpful
                        • 9. Re: AE 2017 playback slow
                          TheOriginal150mph Level 1

                          Thanks for all the insight Roei, once again your awesomeness in unparalleled!

                           

                          I have my previews at "up to 100%" and on my laptop theyre usually showing at 50%. I guess my laptop was chugging away fine with default settings for these first weeks of learning AE and I got spoiled thinking it'd keep up with real-time previews, until I added something memory-intensive that was the "final straw" and it showed me who's boss

                           

                          Since you looked at my .aep, I wonder if you'd thought about any peculiarities in my beginners production process? Suggestions welcome!