2 Replies Latest reply on Apr 17, 2017 7:57 PM by Amebr

    Aliasing Problem: res://ieframe.dll/dnserrordiagoff.htm#mk:

    susanatdell Level 1

      I have had this problem a few times before and I need to get to the bottom of it. 

       

      I just aliased about 12 tabs in a dialog box and most of them worked. One, however displays an error message when I hit F1.

       

      I looked at the address in properties of the error message and compared it to the address of tabs that worked, and it showed

      res://ieframe.dll/dnserrordiagoff.htm#mk:@MSITStore:C:\Program%20Files\Statistica\Statistica%2013\version6.chm::/redirect/DMNode sA/StabilityAnalysis/WorkspaceNodeStabilityAnalysisEditParametersAdvancedTab.htm

      Compared with the link of a aliased file that works:

      mk:@MSITStore:C:\Program%20Files\Statistica\Statistica%2013\DMNodesA.chm::/BasicStatistics /StabilityAnalysis/WorkspaceNodeStabilityAnalysisEditParametersGeneralTab.htm

       

      So the broken one has res://ieframe.dll/dnserrordiagoff.htm#mk:

      at the beginning and has "redirect" in it. It also points to the wrong project. This is a group of merged projects and we alias in a different project that where the topic resides.  And we are using RoboHelp 7.  I just have to get through this one more release and we are upgrading and reorganizing, but I do have to solve this problem with what we have.

       

      Where could this problem happen?  The structures of both topics are the same in the ali file of the project where it is aliased.  I also looked at the h file and it looks correct.

      But that Help ID is obviously not pointing to the correct place.

       

       

      That one topic displays in the TOC correctly, but doesn't show up in search.  The rest do.

       

      I have used the map ID to unmap and remap many times and it doesn't make any difference.

       

      Does anyone know what I can do or what file I can edit to fix this problem? It's already taken up way too much of my time. 

       

      Thanks,  Susan

        • 1. Re: Aliasing Problem: res://ieframe.dll/dnserrordiagoff.htm#mk:
          Captiv8r Adobe Community Professional & MVP

          Sorry, but you totally lost me when you said you "aliased" things.

           

          What the heck does that mean to you?

           

          Cheers... Rick

          • 2. Re: Aliasing Problem: res://ieframe.dll/dnserrordiagoff.htm#mk:
            Amebr Level 4

            First, I'd suggest triple checking that the path is set up correctly in your CSH mapping. I know you said you already did, but I've been caught out by that a lot. So go through character by character and make sure it's right.

            EDIT: And make sure you have the correct ID from the application, and that your developers have the correct/latest version of the map files.

             

            Another thought is that the hhp file contains "old" hard-coded paths. Take a backup of the hhp in case anything goes wrong. Open the hhp file in a text editer, find the  [MERGE FILES] section, and make sure the paths to all the chms are relative paths and also correct. Delete any extra rows. Rebuild your chm.

            I can't offer a permanent solution, so you may need to do this each time you generate or at least regularly - I could never figure out why the paths would get (re-)added.

             

            As it's a different chm file, it's possible that somehow that file fell afoul of Microsoft security measures. Try right-clicking on the chm, selecting Properties and see if there is an Unblock button. If there is click it and see if that fixes the issue.  I'm not sure how you would solve this permanently, if the chm is being downloaded/copied from the internet or opened from a network drive. If it's being shipped with an application, then making sure it's unblocked before it's packaged with the application "should" work.

             

            I also found this old thread which may or may not help:

            https://social.msdn.microsoft.com/Forums/ie/es-ES/2eb96418-e944-4ee9-a4f3-ff28980c36a2/res ieframedlldnserrorhtm?forum=ie…

            The registry keys would be a per computer solution, although it's possible your application might be able to set them - you'd have to talk to your developers though.

             

            Captiv8r I believe 'aliased' means mapping CSH IDs.