4 Replies Latest reply on May 24, 2017 3:00 PM by CobaltBlue72

    AE 14.2 Mercury GPU acceleration slower than Mercury Software Only (Trashcan Mac)

    CobaltBlue72 Level 1

      I have run test renders on multiple projects with the latest AE 14.2, comparing the "Video Rendering and Effects" Project Settings set to

       

      "Mercury Software Only"

      "Mercury GPU Acceleration (OpenCL)"

      "Mercury GPU Acceleration (Metal)"

       

      Unfortunately the GPU accelerated modes appear to slow down render time significantly - renders are almost twice as long, with Metal being marginally less slow. To showcase - a test render comp is one text layer with either box blur or fast box blur ramping blur radios from 3 to 30 and iteration set to 12. Renders were each done on a 12-core late 2013 AMD Fire Pro D700 Trashcan running OS X 10.12.4 with caches purged and on local drive to eliminate any network traffic influence.

       

      12 seconds with mercury software only - box blur

      05 seconds with mercury software only - fast box blur

       

      20 seconds with mercury GPU acceleration OpenCL - box blur

      05 seconds with mercury GPU acceleration OpenCL - fast box blur

       

      19 seconds with mercury GPU acceleration Metal - box blur

      05 seconds with mercury GPU acceleration Metal - fast box blur

       

      When I tested these modes in the previous 14.1 AE version (using the regular old box blur) the results were similar.  So it appears the Project Settings have no influence on the GPU accelerated effects and a negative influence on regular effects. Oh Adobe - so promising, yet so vexing...

       

      [Moved from non-technical Lounge Forum to specific Program forum... Mod]

      [Here is the list of all Adobe forums... https://forums.adobe.com/welcome]