2 Replies Latest reply on Apr 28, 2017 8:18 PM by Ashley7

    Using Cinema 4D, unexpected portions of invisible nested comp appearing

    Ashley7 Level 3

      Using Cinema 4D across several nested comps, I have one layer which is a composition that itself has several layers of comps etc. That one layer is at Opacity=0%, invisible. However, there's a portion of a comp nested within that comp which is appearing in the active camera view as well as other views... let me refer to that portion as an artifact.

       

      It's odd because things have been working fine. I've made several comps already which nest the same base comps... I've made separate copies for each scene to ensure I don't make a change negatively affecting other scenes.

       

      I'm in a situation now where, to try to isolate this problem, I've tried lots of things such as copy/pasting to a new comp, trying process of elimination etc...  I do something silly like change Ambient light intensity from 100% to any value other than 100% such as 99% or 101% and the artifacts disappear. I tried to disable or even delete layers to find the culprit but there is no one combination... the one pattern I see is that any random tweak to the main comp causes those artifacts to either all appear or disappear. I even created a shape layer and it caused them to disappear... but when I tweak something else, they reappear.

       

      More detail on my comp's layers...

      <shapes, text, camera and null objects>...

      CompL1->Level2Comp->Level3Comp(has 2 layers of Level4Comp)->Level4Comp->Level5Comp(has 16 layers of Level6Comp)->Level6Comp

      CompL2 (same as CompL1)

      CompL3 (same as CompL1)

      CompL4 (same as CompL1)

      SomeOtherComp

       

      Each artifact (of which their can be 4, seemingly corresponding to the above 4 layers) consist of a rendering of Level3Comp except for one of its shapes. Level3Comp has 3 layers, two of which are Level4Comp, 1 of which is a shape layer. The shape layer does not appear. Just the Level4Comp renderings.

       

      Oddly, when I am viewing Level4Comp and disable the layer referencing Level5Comp, the artifacts remain visible while viewing Levell4Comp. If I go into Level5Comp and disable all of its layers, all of which reference Level6Comp, then I go back to Level4Comp, the Level5Comp rendering is gone (artifacts gone). First, disabling Level4Comp's ref to Level5Comp should have done just, but it did not. Then going to Level5Comp and disabling each layer causes the Level4Comp to not display the artifacts. Puzzling that disabling level 4 does not do that, but disabling all layers of 5 does do that. .

       

      I've been thinking corruption or some such that I rebooted etc. but problem persists.

       

      The one thing... for my prior scenes which were successful, I imported the AE project to itself instead of manually duplicating the reused portions (those layers mentioned above). Intead of manually duplicating and using alt-drag to replace comps with the right copies, I imported to the AE project from the AE project to get new copies, then renamed them, deleting what I didn't need. (That works great by the way.) For this scene,though, I tried to use the manual copy method. Not sure if this is related but mention it fwiw.

       

      I'm probably going to go try starting fresh with an import of those reused comps see what happens. All comps are Cinema 4D, and I've double checked that all layers with comps/shapes have 3D active and the Collapse Transformations star selected. Everything looks fine... as mentioned I've been working with these layers for a few days without issue now this.

       

      Does anyone have any ideas on what is up?