6 Replies Latest reply on May 24, 2017 2:41 PM by Kevin-Monahan

    I can't hide a white line in Shape Layer

    Muhsin Huduti

      Hi,
      I cant remove this white line, even if hide it.
      I tried everything, can someone help ?

       


       

      Thanks!

        • 1. Re: I can't hide a white line in Shape Layer
          Roei Tzoref Adobe Community Professional

          cropped screenshots is a big NO NO here. we can't see what goes on there. show us more please. all the layers, all the interface. select all the layers and and press UU so we can see all the modified properties. more information about your project could be helpful too, as well as Ae version and OS full numbers. don't worry, we'll find the sucker

          • 2. Re: I can't hide a white line in Shape Layer
            Muhsin Huduti Level 1

            I'm running Windows 8.1 64bit

            • 3. Re: I can't hide a white line in Shape Layer
              Rick Gerard Adobe Community Professional & MVP

              The first thing I would to to diagnose the problem is solo the shape layer to see if the white line comes from that layer. If it doesn't then start turning off layers until you find out where it is coming from.

               

              It appears you want a black stroke and you are using trim paths, but you also have a fill. Trim path's don't really work as you would expect when you have a fill so If you don't need the fill turn it off or delete it.

               

              Second, you have a track matte applied to the image of the girl. I'm not sure what the track matte is hiding but you'll want to try turning the track matte on and off to see what it is doing.

               

              If that doesn't point you to a solution try turning off all layers and then turn them on one at a time until you see the white line and go from there.

              • 4. Re: I can't hide a white line in Shape Layer
                Horshack Level 4

                That white line looks like the constraining border around a repositioned image layer (wont show up in render). Even though you have mask/shape path visibility turned off in the composition viewer (the wireframe icon to the left of the timecode), AE will still show layer handles unless you turn off all visual controls via the menu item "View -> Show Layer Controls" (shortcut is Ctrl+Shift+h)

                • 5. Re: I can't hide a white line in Shape Layer
                  Roei Tzoref Adobe Community Professional
                  That white line looks like the constraining border around a repositioned image layer (wont show up in render).

                  if it was the bounding box constraining border, it would be in the color of the layer and the wireframe would only be visible on the grey pasteboard, not the composition area. if the layer was selected, you would also see some scaling handles (little square fills) and they would be visible in the composition area as well.

                  we can only guess at this time. my guess is that the photos itself (the source) has a white border. you could know for sure if you click on the photo layer twice and observe it in the layer window.

                  if this is the case, to fix this I recommend applying a mask that will obscure it. you are better off doing it in the layer window where you can see the whole layer. choose the rectangle tool from the tools menu (or press Q) and click-hold and drag across the image until you frame it like this:

                  I labeled the mask in red so it is more clear

                  • 6. Re: I can't hide a white line in Shape Layer
                    Kevin-Monahan Adobe Employee

                    Hi Muhsin%20Huduti,

                    You had a lot of advice here. What ended up working for you? Please let us know.

                     

                    Thanks,
                    Kevin