4 Replies Latest reply on May 2, 2017 2:27 PM by Roei Tzoref

    Problem with collapse layers + precomps

    Litwak57

      hello,

       

      currently going crazy because I have two comps that seem to be identical in all ways but for some reason the collapse layers is working in one and not in the other. I'm trying to add engines (made up of a Video Copilot flare + Video Copilot Saber solid) to the back of miniature spaceships which i've tracked and put inside a precomp. as you can see, i want the red engine to ADD into the background but its not showing up as ADD (look at disembodied engine next to it as an example of the way it should be.

       

      Screen Shot 2017-05-02 at 12.10.21 PM.png

       

       

      and here is the other comp where its WORKING with an example of the red engine next to it proving that it's not something to do with the ENGINE PRECOMP or the SHIP PRECOMP

       

      Screen Shot 2017-05-02 at 12.11.19 PM.png

       

      if you look next to the collapse transformations thing, the blend mode on the working one has a dash through it, that's the only difference I can see as to why it's not working but I have no idea why!!

       

      and here are pics of the precomps themselves

       

      Screen Shot 2017-05-02 at 12.10.53 PM.png

       

      Screen Shot 2017-05-02 at 12.11.27 PM.png

       

      please help, I will be so grateful!

       

      -Michael

        • 1. Re: Problem with collapse layers + precomps
          Szalam Adobe Community Professional & MVP

          Check inside the engine precomp. There might be something screwy in there.

           

          Also, what, exact version of AE is this?

          What happens if you move forward a few frames?

          • 2. Re: Problem with collapse layers + precomps
            Litwak57 Level 1

            GAHHH I FIGURED IT OUT

             

            apparently despite having the a hue/saturation effect and mask turned off, for collapse transform gets messed up if you have an effect or mask applied to the outer comp,

             

            so the lesson here is to delete all effects AND masks on the outside of the precomp, turning them off isnt enough

            • 3. Re: Problem with collapse layers + precomps
              Szalam Adobe Community Professional & MVP

              Thanks for sharing what it was. Sounds like that classifies as a bug to me, by the way. You can report it here. Please include as much detail as you can. For example, did your effects use any compositing options such as masks?

              • 4. Re: Problem with collapse layers + precomps
                Roei Tzoref Adobe Community Professional

                so the lesson here is to delete all effects AND masks on the outside of the precomp, turning them off isnt enough

                one of the Gotchas of collapse transformations. it's written here: Precomposing, nesting, and pre-rendering After Effects compositions "When a closed mask (with mask mode other than None), a layer style, or an effect is applied to a nested composition with collapsed transformations, the layers in the nested composition are first rendered on their own, then masks and effects are applied, and then the result is composited into the main composition. This rendering order means that the blending modes of the nested layers are not applied to any underlying layers in the main composition, and that 3D layers above and below the collapsed layer cannot intersect or cast shadows on each other."

                 

                so the question is: what is an "applied effect"? for now, as long as it's in the layer it's consider applied. I think we could ask that even not enabling it (turning off the master effect switch or effect switch) will constitute as not applied so this will be less confusing in the future. BTW, layer styles that are there but not enabled do work this way - so why can't effects?

                 

                but you need to ask for it in the link Szalam provided.