2 Replies Latest reply on May 8, 2017 6:21 AM by tabmc

    Android build fails with no reason - Can anyone advise?

    tabmc

      Hi.

       

      My app is building to windows, but it fails for android.

      The log simply states a one-liner:  "Build Date: 2017-05-04 17:50:25 +0000"

       

      The following is my config.xml - if anyone has any ideas I'd be grateful

       

       

      <?xml version="1.0" encoding="utf-8" ?>

      <widget xmlns = "http://www.w3.org/ns/widgets"

          xmlns:gap = "http://phonegap.com/ns/1.0"

          xmlns:android = "http://schemas.android.com/apk/res/android"

          id        = "mac.merchant.app"

          version   = "1.0.0">

          <name>Order Taking App</name>

          <description>

              Order Taking App

          </description>

          <author email="info@xxxxx.co.uk" href="http://cordova.io">

              xxxxl.uk

          </author>

          <icon src="icon.png" />         

          <content src="index.html" />

                   

          <preference name="orientation" value="portrait" />

          <preference name="android-build-tool" value="gradle" />  

            

          <gap:plugin name="cordova-plugin-whitelist" source="npm" />

          <gap:plugin name="phonegap-plugin-push" source="npm" spec="1.5.3" />

          <gap:plugin name="cordova-plugin-device" source="npm" />      

          <gap:plugin name="cordova-plugin-inappbrowser" source="npm"  />      

          <gap:plugin name="cordova-plugin-splashscreen" source="npm" />  

          <gap:plugin name="cordova-plugin-geolocation" source="npm" />

          <gap:plugin name="cordova-plugin-network-information" source="npm" />

       

          <gap:splash src="splash.png" />

          <preference name="AutoHideSplashScreen" value="false" />    

          <preference name="SplashScreenDelay" value="10000" />

        

          <gap:plugin name="cordova-plugin-googlemaps"  source="npm" spec="1.3.9" >

             <param name="API_KEY_FOR_ANDROID" value="AIzaSyDJ7-KJ2--O_NF9WYTO7syMUi5kOP7D-y7" />

             <param name="API_KEY_FOR_IOS" value="XXX" />

          </gap:plugin>  

        

          <gap:plugin name="cordova-plugin-media" source="npm" />

          <gap:plugin name="cordova-plugin-x-toast" source="npm" />  

          <gap:plugin name="cordova-plugin-buildinfo" source="npm" />  

        

          <access origin="*" />

          <access origin="tel:*" launch-external="yes" />

        

          <gap:config-file platform="android" parent="/manifest">

              <supports-screens android:xlargeScreens="true" android:largeScreens="true" android:smallScreens="true" />

              <application android:theme="@android:style/Theme.NoTitleBar" >          

              </application>

          </gap:config-file>  

        

      </widget>

        • 1. Re: Android build fails with no reason - Can anyone advise?
          ryanskihead Adobe Employee

          Looks like a permissions issue on some of your assets. Try running 'chmod -R 755 ./www', then rezip and reupload.

          • 2. Re: Android build fails with no reason - Can anyone advise?
            tabmc Level 1

            Thank you @ryanskihead - this seems to have worked!

             

            SInce I was using Windows I initially tried to change the permissions using right-click properties box in Windows explorer.

            This did not remedy the problem however

             

            So then I uploaded all my files to a remote server using Filezilla. At this point I was able to right-click within Filezilla and there was an option to change file permissions. So I changed everything to 755 and then downloaded everything back to my laptop.

            Then rezipped and reuploaded and it worked !

            If anyone knows a simpler way in WIndows please share. I'm new to this and stumbled through basically, but if anyone else is having the same issue its worth a try if you're on WIndows.