18 Replies Latest reply on Nov 22, 2017 12:27 AM by Zachary Pariah

    Eraser function doesn't work properly with my Wacom Tablet

    rhrth Level 1

      Hi everyone.

       

      I've been struggling with an issue now for a couple of months and I'm really annoyed at not being able to work as I have for the past 10 years using tablets and Photoshop.

       

      I typically map the eraser function to the bottom side button on my pen for the Wacom Intuos Pro Medium. That's how I've been erasing for many years and how I love painting – I have the brush tool, paint some, and then when I want to erase I just hold in the eraser button and then release.

       

      Here's the problem: When I hold in the eraser button, and erase one or more times, it immediately reverts back to the brush tool even if I still have the eraser button pushed down and haven't released it! This didn't happen during all my years using Photoshop and Wacom tablets. I didn't tamper with it either. I've tried previous Photoshop versions, other drivers for the Wacom tablet, and nothing (I've tried it all!) seems to work.

       

      Here's a video of the issue:

       

      The Wacom diagnostics say the Wacom tablet works perfectly fine, and I've had intensive customer replies through Wacom support, and in the end they told me I probably should turn to Adobe...

       

      What do you guys think? What can I do? Reformat the entire computer? Time Machine?

       

      Macbook Pro 2014 Retina

      El Capital 10.11.6

      Wacom Intuos Pro Medium

      Photoshop CC 2017