2 Replies Latest reply on Oct 6, 2008 1:07 PM by Ed_Miller

    ARRGGH- Annoying slide show problems

    ThePath
      OK. Im really stuck here.

      I have made a slide show in Flash 8 using actionscript 2. Ive managed to succeed to a point. But I will tell you prblems and hopefully they can be solved here as Ive found no where on web that can.

      Problem1: I have a slide show with 5 slides all in the parent of 'presentation'. I have input actionscipt code to allow the current slide to go to the next slide at the end of the timeline. I then linked the last slide with the first slide. Why oh why does this freeze on it 2nd loop through the slides on the 3rd slide. I just dont get it!! It plays once then freezes on the 3rd slide?!?!?!?!?

      Problem2: I have put this actionscipt code against a button, why doesnt it work when it does for other people?
      on(release){
      getURL(" http://www.mysite","_self");
      }

      If anyone can help please do.
        • 1. Re: ARRGGH- Annoying slide show problems
          ThePath Level 1
          Can anyone help please!!

          Here is the code that Doesnt work to good:

          The link code goes as follows: (these links dont work and I dont know why?)

          on(release){
          getURL(" http://www.mysite","_self");
          }

          The next slide code goes as follows:

          stop();
          function goNext(){
          currentSlide.gotoNextSlide();
          clearInterval(timer);
          }
          var timer = setInterval(goNext, 500);

          The go to first slide goes as follows:

          stop();
          function goNext(){
          _root.presentation.gotoSlide(_root.presentation.slide1);
          clearInterval(timer);
          }
          var timer = setInterval(goNext, 500);

          As I say it all works until 2nd loop and then stops on 3rd slide....?
          • 2. Re: ARRGGH- Annoying slide show problems
            Ed_Miller
            Regarding Problem2, the http://www.mysite is not a full URL (i.e. http://www.mysite.com). If the page is simply coming up not found, I'd check the URL. Also, are you using Actionscript 2 or 3? I believe there is a different command for AS3.

            As far as the first problem, can you post a SWF file? I would also try and move the stop(); command to after the next interval is set.