2 Replies Latest reply on Nov 16, 2017 11:21 PM by markretzloff

    ARMS SPINNING AROUND IN THE NEW WALKING BEHAVIOR in CH

    eliahou ericb76912371

      I HAVE BEEN WORKING WITH THE NEW WALKING BEHAVIOR

      I have been working with the new wonderful walking behavior on a pupette - but cannot overcome a problem regarding the arms. it seems they are moving like spinning in circle all around and wont stay in place...I tried playing with the arm angle an swing button with no success.  what should be the default position in the walk behavior.

      I would be happy to send you the puppet to check. you can have a look on a work I did using Character animator in here:

      HORA - YouTube

      thank you from Tel Aviv. Eric

        • 1. Re: ARMS SPINNING AROUND IN THE NEW WALKING BEHAVIOR in CH
          oksamurai Employee Moderator

          Sure - Could you share here or DM me your .puppet file (File > Export > Puppet) via a shared link on Google Drive, Dropbox, or Creative Cloud to take a closer look?

           

          In a scene, if you press the little X next to a parameter it will reset back to the default one you've set in rig mode.

           

          The crazy arms I've seen from examples are a) not having all Body parts tagged - make sure you have them all for best results, or b) positioning issues if using on a non profile/side view character.

          • 2. Re: ARMS SPINNING AROUND IN THE NEW WALKING BEHAVIOR in CH
            markretzloff

            I was having a similar issue.

             

            Under the Walk behavior, I have Start set to "With Left & Right Arrow Keys"

             

            I would click on the Arm Angle dial to make an adjustment and then test it in the scene by hitting my left/right arrow keys. The arms would just go higher and higher until they made a complete circle. 

             

            What I figured out was that the dial for arm angle was still active and the arrow keys were triggering both my character and raising the value of the arm angle dial.

             

            Click outside the arm angle dial to deactivate the dial. Problem solved.

             

            Hope that helps someone. It was driving me nuts.