2 Replies Latest reply on May 15, 2017 11:47 AM by michaellea10309208

    Apostrophes from typekit font only sometimes working?

    michaellea10309208

      Hi all,

      So,  have a VERY specific and somewhat peculiar problem and after scouring the internet to no avail, I was hoping you can help me.

      Basically, I synced a font called Filson Soft which I am using for a logo and branding work--I synced all available options, and before I go more in detail let me just say that I have unsynced and resynced the font multiple times already in hopes that would fix the problem. Also, I'm on Mac Sierra OS version 10.12.4 and all my creative cloud apps/programs are up to date.

      So here is the low down of the issue: The font in question has stylized apostrophe's/quotation marks...or at least it's SUPPOSED to. However, sometimes when I type it in it will work, other times it doesn't, and it is very frustrating and I also can't figure out why.

      Screen Shot 2017-05-09 at 11.09.16 AM.png

      Above is a screenshot directly from the typekit website. You see how the apostrophe/quotation mark looks? That is how I want it to look all the time. But yet, it doesn't. At first when I started working with the font in illustrator it wasn't working at all, so I assumed the preview on the website was just wrong. However, today I tried to see what it looked like in photoshop on a whim and it worked! But when I tried it again, it didn't work. What?

      Screen Shot 2017-05-09 at 10.59.05 AM.png

      Screenshot is from photoshop. You can see where I typed the apostrophe in and it worked on the top. This was the first thing I typed in, and when I tried to type more on a different text layer it used the different apostrophe that I DON't want (you can see it in the "it's", and right before the WHY). I went back and tried to type an apostrophe again on the same text layer that originally worked and it was still the wrong apostrophe. I also tried turning the standard ligature button on/off and messing around a couple other ways and no dice.

       

      Then I put back into illustrator.

      Screen Shot 2017-05-09 at 11.32.24 AM.png

      Okay, so you can see that I got it to work a few times. I honestly have no idea how, though. When I typed it in at first, didn't work. Then I absentmindedly copy/pasted the symbols in, in which they were put in automatically as myriad pro...then when I went to change it to filson soft, SURPRISE! It worked! Okay, so then I tried that method a second time, no dice. I tried typing another apostrophe on the same text layer, didn't work. Finally I copy and paste the correct apostrophe into the "copie'd" text and it worked. So, it looks like if I magically somehow am able to manage to get the correct apostrophe through some sort of magic that apparently has no rule to it, I can just copy and paste whenever I need it. But I know and you know that is just not feasible, especially since I am designing a whole brand and brand guide off of this font. It can't just sometimes maybe work. It needs to work all the time, and it's unrealistic to expect a bunch of designers and editors to continously copy and paste apostrophes when there are deadlines to meet.


      I did some further testing in other programs.

       

      Here it is in Indesign;

      Screen Shot 2017-05-09 at 10.54.10 AM.png

      Indesign didn't work. (I typed it in, didn't try the copy paste thing like I did with ai and ps.)

       

      Next, after effects.

      Screen Shot 2017-05-09 at 11.44.31 AM.png

      Again, didn't work.

       

      Here's the funny/weird part though. I put it into Premiere, and...

      Screen Shot 2017-05-09 at 11.07.43 AM.png

      In premiere it works just fine. I tested it out multiple times even. It's completely fine in that program.

       

      So.....I hope I was as thorough as possible so that you can see what my issue is. Hopefully there is a very simple solution that I am just ignorant about...even though I would feel a bit dumb, I would rather just press a few buttons and have the issue fixed so I can move on. I'm really hoping this isn't a problem with the type itself, because it is perfect for the brand I am working on and have already done a lot of work for using this font.

       

      Thanks for your time.