31 Replies Latest reply on Apr 27, 2018 7:23 AM by D Fosse

    Changes don't take effect until zooming in & out (Photoshop CC)

    clintself Level 1

      At work, I use a Late 2015 27" Retina iMac (5K). 32GB RAM, 512GB SSD. I've had the computer for a little over a year, and never had any issue with it until a little less than a month ago, when Adobe CC came out with an update. Since said update, I've had major issues with Photoshop. It's a little hard to explain without showing it, but it's basically not showing me certain changes on a file until I either 1) zoom in & out, 2) change the size of the window, 3) save the file. Everything isn't affect, but most fundamental things are affected.

       

      In a nutshell, here's what's mainly affected:

      • If I click the "eye" icon to hide or show a layer, the layer will usually change once then never again.
      • If I change the blending mode on a layer, the layer will remain unchanged.
      • If I mask out part of a layer, the layer will remain unchanged.
      • If I change the layer order, the graphic remains unchanged.
      • If I nudge a layer with the Move tool & my arrow keys, nothing happens until the 3rd or 4th attempt.

       

      Here's how I've troubleshot:

      • Googled
        • The problem seemed to come up in versions of CS4 & CS5, but nobody else seems to be experiencing the issue currently.
      • Restarted photoshop
        • Nothing changes
      • Deleted preferences file
        • Problem is solved for about 20 minutes, then it returns.
      • Went to my company's IT guys - they suggested looking for updates to my apps, OS & video card.
        • AMD doesn't release updates for Mac video cards
        • CC apps & OS were 100% up-to-date
      • Consulted Adobe Support - the tech couldn't give me a straight answer why this was happening other than constantly blaming Apple. He took control of my computer, deleted my preferences file, and disabled the Retina option specifically for Photoshop. He said that this was an issue that Adobe was aware of on the 5K Retina iMac only (remember this note for later).
        • This seemed to be a nice band-aid for about a day, but the problem soon returned. On top of that, this "remedy" really didn't work because it lowers the quality of Photoshop dramatically. Working in 300dpi files intended for printing just don't work when all you see is pixels.
      • Reinstalled Photoshop
        • This seemed to be the only thing that consistently worked. However, it's nothing but a band-aid, because the problem comes back by the end of the workday. Plus, it's not fun reinstalling your apps every morning before you can even start work.

       

      So that's where I'm at. Couldn't get any worse, right? WRONG! The issue that was supposed to be exclusively a Retina iMac issue, (according to the Adobe rep) suddenly appeared about a week later on my brand new MacBook Pro (15" 2016 with Touch Bar, 2.7 GHz i7, 16GB RAM, 512GB SSD, Radeon Pro 455).

       

      I really need some help on this! I'm not sure what to do anymore. My last option is to move to an old copy of CS5 that our IT department has held onto. As I use many of the new features released since then, this is barely an option for me.

       

      Any & all help is greatly appreciated!