1 Reply Latest reply on May 27, 2017 3:38 AM by BKBK

    Default ScriptSrc folder plus strictnumbervalidation

    samd

      I have a ColdFusion 11 server set up and I've set one up and it works fine with no problems. However on another server that is built I can't get the following working at the same time together.

       

      I have my DefaultScriptSrc pointing to a newly named virtual directory in IIS as per the lockdown guide. For instance I have a virtual directory called "cfscripts".  This virtual directory points to the CFIDE\scripts directory in IIS.  Therefore in CFadmin I have the parameter set to "\cfscripts\"

       

      1. Cfform works just fine.  You can clearly see that it's looking for cfform.js in src="/cfscripts/cfform.js"

       

      2. However we set the parameter "strictnumbervalidation=false" at the top of our code in the apps as we want it to behave like in prior ColdFusion releases.  This does not work.

       

      If I change the virtual directory cfscripts to point to CFIDE instead of CFIDE\scripts then the strictnumbervalidation works but the cfform doesn't. I'm not sure why on this server it works this way.

        • 1. Re: Default ScriptSrc folder plus strictnumbervalidation
          BKBK Adobe Community Professional & MVP

          If, as you say, you followed the lockdown guide, then verify that your settings are as follows:

           

          Virtual directory alias in web server for cfscripts folder: /cfscripts

          Physical path: {cf.instance.webroot}/CFIDE/scripts

           

          Value for "Default ScriptSrc Directory" in ColdFusion Administrator: /cfscripts/

           

          Should you make any changes, you should restart ColdFusion.