5 Replies Latest reply on Nov 18, 2017 1:47 AM by Peter Grainge

    Runtime Error When Publishing

    criswelljulie

      Hello,

      Several weeks ago I was given a new laptop with Windows 10.  I reinstalled all of my Adobe products including RoboHelp 2017 (13.0.1.27)and Captivate 9.

      We use RoboServer 9.

       

      Last week I uploaded a new SWF Captivate file to RoboHelp and then attempted to publish.  Repeatedly I get a  Runtime Error Program:...es(x86)\Adobe\Adobe RoboHelp 2017\RoboHTML\RoboHTML.exe  abnormal program termination.  RoboHelp immediately crashes once I acknowledge the Runtime error.

       

      I removed the newly uploaded SWF file and attempted to re-publish but it still fails.  I always check to see how far into publishing it gets before it fails and it will randomly fail on another SWF file or a PDF - all files which have previously published for over a year.

      • I've tried deleting my .cpd file.
      • I've uninstalled RoboHelp and Captivate and reinstalled.
      • Needless to say I have had many reboots since.
      • I have tried publishing other projects and the results are hit and miss.  One time they will publish and the next time they won't.

       

      I've searched forum after forum but haven't found quite the same problem and yet I tried every solution listed with no luck.

       

      Is there anyone out there with a similar situation that has resolved the issue?  I'm scared that my entire RH project has become corrupted somehow.

       

      Thanks in advance for reading this and offering any guidance or suggestions!

      Julie Criswell

        • 1. Re: Runtime Error When Publishing
          criswelljulie Level 1

          Sadly, this is once again an issue for me - well, in reality, it never stopped being an issue.  I had one successful publish and since then, I've never performed a Republish All action.  As long as I just published changes, it was successful.

          However, today, the project was inadvertently deleted from the server and now I have no choice but to republish all files.  I have repeated the steps mentioned in my original post again to try to get it published.  It failed on one PDF, so I deleted that PDF for now -- just as a test but it failed on a different PDF.  So I deleted and then re-imported all the PDF baggage files and removed the hyperlinks referencing those PDFs and and re-added the links back in.  Still fails.  Other attempts where it seemingly moves past the PDFs, it gets hung up on a Captivate SWF file.  Keep in mind, this is not a new project or even new PDFs or Captivate SWFs, it has successfully published for at least 2 years prior to this issue 6 months ago and now.

          • 2. Re: Runtime Error When Publishing
            Peter Grainge Adobe Community Professional (Moderator)

            Is RoboHelp Server 9 compatible with Rh 2017? Check Adobe's site or Support.

             


            See www.grainge.org for RoboHelp and Authoring information

             

             

            @petergrainge

            • 3. Re: Runtime Error When Publishing
              criswelljulie Level 1

              I chatted with support and confirmed that WebHelp Pro publishing from RH 2017 to RH Server 9 is compatible. I am trying to see if they can offer any other assistance about this particular project’s problem  

               

              Thanks Peter!

               

              Julie

              • 4. Re: Runtime Error When Publishing
                criswelljulie Level 1

                Just ended chat and remote session with Adobe Support.  He did a lot but in the end he said what allowed him to publish finally - were the following steps:

                 

                1. Delete CPD
                2. Delete XPJ
                3. He moved Project Folder from My Docs on C Drive to new location on Desktop (I would guess this would be optional)
                4. Start RoboHelp > File > Open > Project Folder Location > Choose HHP File
                5. Open project as HHP file. 
                6. Generate
                7. Publish - It finally published all files.

                 

                I have since just opened the project using the standard .xpj file and have generated and published successfully.

                However, one caveat I will mention - is that it is now publishing with a hybrid of two different skins - but that is a problem I can work on tomorrow as long as the content is there!!

                • 5. Re: Runtime Error When Publishing
                  Peter Grainge Adobe Community Professional (Moderator)

                  I am surprised to see that was the solution. It is a known way of opening a corrupt project (it's on my site for that purpose) but I wouldn't have thought of it in this connection.

                   

                  I have edited your post to number the steps and I think that Step 3 is what fixed it and probably would have done so alone. Behind it is likely a long path that exceeded the number of characters Windows supports. I didn't consider that as you had published before but likely you added something that just ran over the limit (256).

                   

                  Using that method, certain things may have been lost. You need to take a look at Opening Corrupt RoboHelp Projects on my site and check them out.

                   


                  See www.grainge.org for RoboHelp and Authoring information

                   

                   

                  @petergrainge