6 Replies Latest reply on May 29, 2017 1:48 AM by Peter Grainge

    Problems with .cpd file

    phillipr1524

      Hello to all,

       

      I'm having problems with a .cpd file in Robohelp 2017. It's currently 243Mb in size, but I can't deleted and regenerate it. I've tried renaming it and deleting it, but nothing seems to work.

      I get the following errors when I try to open a new project after the .cpd file has been deleted:

       

      .cpd1.png

      .cpd2.png

       

           .cpd3.png

      A new .cpd file is created and is about 836Kb in size. The project runs through its start up but hangs at the 'ready' stage. If I then try to reopen another project everything opens, but the ToC is missing and all other links are broken. If I then close this down, reinsert the massive .cpd file it loads ok and rebuilds the project, but is still very sluggish.

       

      If there is anyone out there who can help and offer advice I'd be very grateful.

       

      Phill

        • 1. Re: Problems with .cpd file
          Amebr Level 4

          Is Z: a network drive? RH performance is highly dependent on network performance, so some of your issues could be related to your network.

           

          If you have one, use a copy of the project from before you started messing around with the cpd.

           

          Try putting a copy on your c: drive, preferably a short path like c:\temp.

           

          Does it open quicker?

           

          Try deleting the cpd and re-opening. Does it work this time?

          • 2. Re: Problems with .cpd file
            phillipr1524 Level 1

            Hi Amebr,

             

            Yes, the Z: drive is a local network drive. I tried deleting the .cpd file and moving the project onto the C: drive but when I tried to open it I got the same error messages.

             

            I also suspect that some of the issues are network related, however, that area is totally out of my control.

             

            Phill

            • 3. Re: Problems with .cpd file
              Amebr Level 4

              One of the things I've come across is that deleting the cpd can lose some information if Robohelp gets particularly borked.

               

              If you have a copy from before you first deleted the cpd, that would be ideal. Put the copy on your c drive - don't delete anything before copying the files. Then once it's on C: delete the cpd and open the project.

               

              Also, avoid the desktop or your user directory as in some corporate environments these are actually network locations.

               

              If you don't have a copy from before, then we can look at your rhbag.apj file which might have become corrupt.

              • 4. Re: Problems with .cpd file
                phillipr1524 Level 1

                Hi Amebr,

                 

                I followed your advice and still nothing. I've also had error messages with the rhbag.apj file (images below). This morning I came in and the search function is now not working and the following error message is present "Failed to initialize database".

                 

                The rhbag file issues:

                rhbag1.png

                I've also had a similar message with a <5> to end it. I have read forum replies about similar problems asking for the rhbag file to be opened and to check the HTML, but I'm not an expert there and it all looks the same to me!

                 

                Once again, help would be very welcome.

                 

                Regards,

                 

                Phill

                • 5. Re: Problems with .cpd file
                  Amebr Level 4

                  One other thing I just thought of. If the project is very large, then follow the previous instructions just as you're leaving for lunch and let if run for a good hour - in a previous job we had one project that would take at least 45min to do its thing when the cpd file was deleted.

                   

                  Now, the rhbag.apj file basically stores a list of baggage files in your project (for example Word or PDF files, typically, but may be other types of files).

                   

                  To check if a corrupted baggage file is causing the issues, create a new blank project - this should create a new baggage file with nothing added. Take a backup of your existing rhbag.apj file so you don't lose anything, then paste the file from your blank project. Delete the cpd file and open the project. Does it complete now?

                   

                  If it works, then the rhbag file was corrupted.

                   

                  Theoretically you can copy the rhbag file from a known working copy of your project, delete the cpd and reopen the project. However, it's possible that the error has existed for a while, but hasn't manifested until you deleted the cpd. It might be easier to re-add the baggage files manually, if you don't have too many. If you have a lot, if you can post the content of the rhbag file, we might be able to spot the issue.

                   

                  In RH11, the file is basically a bunch of <file> section with the following file information:

                  name = project folder path and filename

                  usercreated = whether you manually added the baggage file or RH added it automatically

                  comments = not sure, this is always blank for me.

                   

                  If there are no baggage files, then there are only about 4 lines in the file

                   

                  The format in RH2017 may be different, but I expect it would be similar to this. Things to look out for would be missing end tags for file, name, usercreated; odd symbols in name.

                  • 6. Re: Problems with .cpd file
                    Peter Grainge Adobe Community Professional (Moderator)

                    If what Amber has suggested does not work, take a look at Opening Corrupt RoboHelp Projects on my site. Maybe you can open it from the HHP file. Do note the warnings about backing up, notwithstanding that what you have is corrupt.

                     

                    Alternatively, if you have a good output, you can recover the project from that using a commercial script from Willam van Weelden.

                     

                    Amber has already pointed out that running a project on a network is dependant on the network itself. You say you have no control over that but clearly if the network is going to give you issues like this, something has to change. Usually the reason IT give is so that your work is backed up overnight. A good compromise is that you work locally and at the end of each day, you put a zipped copy of the project on the network with a filename such as YYMMDD_ProjectNameBackup.zip. The date in that format keeps the backups in order. Periodically prune the backups keeping say the last backup of each month. If necessary involve your line manager in the discussion.

                     


                    See www.grainge.org for RoboHelp and Authoring information

                     

                     

                    @petergrainge