3 Replies Latest reply on Oct 6, 2008 11:11 AM by TrevorMartin

    Installation fails (rolls back) on Windows 2008

    TrevorMartin
      I am trying to install RoboHelp 7 on a new 64-bit Windows Server 2008 system (very similar to Vista) that has never had any Adobe products installed on it. The installation always fails and rolls back all change to the system. Files are being created in the default installation directory (C:\Program Files (x86)\Adobe\Adobe RoboHelp 7), then they are all automatically deleted when the installer fails. I have tried installing repeatedly, rebooted the machine, disabled UAC, ran the installer as the administrator, and tried other ideas I've seen on these forums, but nothing works. I have the exact same problem with Adobe Captivate 3, but not with any other non-Adobe programs I've tried. The exact message in the InstallShield Wizard is, "The wizard has interrupted before Adobe RoboHelp 7 could be completely installed. Your system has not been modified. To complete installation at another time, please run setup again."



        • 1. Re: Installation fails (rolls back) on Windows 2008
          Linux Rules Level 2
          Hello Trevor -

          This reply is conjecture based on facts...I don't think Win08-64bit is supported.

          Facts:
          The operating system needs a mechanism for organizing and managing disk partitions; Windows Server 2008 provides two partitioning styles: Master Boot Record (MBR) or GUID Partition Table (GPT).

          Master boot record (MBR) disks use the standard BIOS partition table originally developed for x86-based computer systems and is the most common style in use.

          GUID partition table (GPT) disks use extensible firmware interface (EFI) originally developed for 64-bit Itanium based systems (advantages of GPT disks are more than four partitions on each disk and supports disks larger than 2 terabytes).

          Windows Server 2008x86 32-bit and 64-bit systems support MBR and GPT partition styles. Note: 32-bit systems can only boot from MBR disk partitions and 64-bit systems can boot from GPT partitions.

          Each partition style has different capabilities and partitioning styles. The two partition styles have very different configurations in terms of special mandatory partitions. In addition, other mandatory partitions are required on each disk style to operate as boot and system disks. In terms of MBR disks a master boot record (MBR) partition is required. On GPT disks, EFI system (ESP) and Microsoft Reserved (MSR) partitions must be present for the disk to be bootable.

          Fact:
          The RoboHelp installer writes to the Master Boot Record (it is by definition a "root kit") where your registration information is stored.

          Conjecture:
          The RH installation can fail if:
          a) the MBR is write protected (to protect the drive from viruses and root kits) or
          b) the hard drive does not have a Master Boot Record.

          Thus, if your 64-bit server uses GPT partitions (you implied this when you wrote "Windows Server 2008 64-bit") then the RH installation may fail as there is no MBR to write to.

          This is all conjecture on my part. You will need confirmation/explanation from Adobe developers.

          Regards,
          GEWB
          • 2. Re: Installation fails (rolls back) on Windows 2008
            Peter Grainge Adobe Community Professional
            Plus

            1] I believe it contravenes the licence if you install RH on a server.

            2] It is not a supported operating system.

            • 3. Re: Installation fails (rolls back) on Windows 2008
              TrevorMartin Level 1
              Thanks for the replies. I was able to resolve this installation problem by doing two things:

              I went to where RoboHelp had expand the installation files (C:\Users\Administrator\Desktop\Adobe RoboHelp 7\RoboHelp) and set all of the EXEs to run in Windows XP compatibility mode.

              I opened a command prompt in this directory and ran the RoboHelp installer directly without user intervention: "msiexec /i "Adobe RoboHelp 7.msi" /passive". This installed RoboHelp using the default options.

              Apparently this is a problem with InstallShield on Vista that has been experienced by many software manufacturers. I got the solution from Symantec from this page: http://tinyurl.com/3g2bl4